Streaming levels starting hidden

It isn’t the first time, I’ve done level streaming using the level blueprint but I’ve never ran in such a incredible problem.

It’s Unreal 5.4 - I have one persistent level with the room, lights and static assets. sub-levels are just for changing the Screens and bring audience into the room.

The sub-levels starting as they should but they’re hidden. I checked everything a hundred times (also compaired it with older projects) but can’t find any wrong settings. I know sometimes it’s just a tick in the right or wrong box… -
I’d very appreciate any suggestions.


  1. persistent level in edit mode:

  2. level blueprint of the persistent level:

  3. persistent level in game mode:

  4. persistent level in game mode after pressing the 1 key:

are you Check the sub-levels outliners?

Thx for your reply. - Yes all eyes are open.

I think I’ve something messed up in the persistent level. The problem was solved by reverting to a backup copy of that level.