Streaming levels freezes the game

I’m working on a game that will have many linked levels and I want to make it seamless. I have transition areas where both levels need to be loaded. I’ve now set this up so that its pretty easy to switch maps “seemlessly”, but it freezes the game while this happens. I would like to do it in the background if possible. Since my main hub area has many transitional areas in it, they ALL need to be loaded with this map. This causes about a 1-3 second delay. I’ll include a screenshot of my load map function, which gets called via a foreach loop. I’ll also include a screenshot of my interface to detect if its done loading or not. When its done loading some actions are performed.alt text

An update on this. I attempted to separate the load and visibility settings into separate functions. Unfortunately I discovered that the freeze occurs at the setting of the loaded option. Toggling the visibility doesn’t seem to have any major impact. However I discovered if you toggle too many visibility options completely without unloading them first, the engine crashes.

So I guess my question now is. Is there any way to load multiple levels in the background without freezing the gameplay? If I can get that issue resolved, I can handle the visibility issue.

1 Like

did you solved this?

1 Like

Anyone ever managed to load streaming levels without freezing the game?

1 Like

How is it possible that there is no reply to this question? Isn’t level streaming Epic’s “answer” to have huge maps that pop in and out of existence based on the player location? Isn’t this what would be required to make a GTA type city?
I’m confused.

1 Like

I think that world partition could solve this problem since instead of loading and unloading entire maps the system handles actors individually. But EU 5.0 seems a bit broken for game developers… I’ll wait for an update to 5.1.

1 Like

I’m having the experience in World Partition of only being able to traverse a few cells, when I get to hard limits that freeze gameplay.

The trigger areas that freeze are consistent, but do not necessarily make obvious sense when I look at the RunTimehash2d. Maybe they correlate somewhat to lines of the preview grid, but not really.

Anyway, if World partition is still buggy maybe that’s it.

I’m also seeing similar behaviour. I use the commands “Ghost” and “Slomo 20” to test fast movement.
The world partition streaming is set to blocking.

When I run away from the cells off the map to unload them all then back in to load them again it won’t block the game for any significant amount of time. After that the game will still be running, animations playing, stats updating, but the character will stop moving and the input will completely freeze. I can’t move, can’t open the PIE console, nothing. If I click on the game viewport the input will resume and I will be able to move and input again. This also appears in builds of the game.

I’m doing more research into this to see what’s up. Is anybody else noticing anything similar?

For me this turned out to be user error on my side of things. Once I fixed up the bugs in game I no longer noticed any freezing.

1 Like