Download

Strategy Game Doesn't Build?

Hello all,

First of all, big thanks to Epic for opening this up. I have been a long time Unreal Engine user and am really impressed with UE4.

I wanted to see if anyone else is having issues with building “Strategy Game” for android? The cooking process takes a while and eventually fails with “BUILD FAILED”. I’ve tried this for various Android build methods with the same result.

Anyone else?

Hi, I have the same problem. Mobile temple, Tappy Chicken and Swing Ninja builds without a problem. I’m also looking for an answer.
For me, I get an error (sorry, didn’t save the log) about the apk not existing.
I suspect that there was some other error in an earlier step that lead to the apk not being built, but I don’t have any more info right now.

I also tried using different texture compressions (etc1, atc, all combined) with no success.

If you’re running into problems with the APK not building out from the editor for C++ projects, you can often work around it by open up your project’s solution in Visual Studio, then building your project for the Development Android environment (or DebugGame/Shipping Android, if that’s what you’re trying to package for).