Strange white line while using FXAA

Hi guys! i’m pretty sure this is a bug, but it might not be. Regardless, I’d like to post something about it.

I’m creating an Oculus Rift horror game right now, that consists of very, very dark scenes. I thought about using FXAA as the Anti-Aliasing method to get better performance out of the game, but ran into a different issue. While using FXAA, I encounter this white line on the screen. It’s always there wherever I move in the game.

It’s difficult to see, so I highlighted it. This also shows up when I do a VR Preview of the game.

However, switching back to TemporalAA, the white line is gone.

That’s the same position from the first image by the way. Everytime I switch between AA methods, it always shows up. Easily recreatable for me.

To add some context to the scene. The scene is comprised of mostly BSP’s, except for parts of the stairs and the railings. Textures are images online, or from the GameTextures Material Pack. The scene also has no Sky Sphere, or Sky Light, as the whole game takes place in this stairwell. I’m using the dust particles that come from the engine.

I’ve since optimized the game to where I can use TemporalAA no problem (yay!), but thought I would bring this to attention. Let me know if you have questions or things you’d like me to try.

Also, quick question: How does the game look so far? This is the first time I’ve worked on something series in UE4.

Hello Hoopera,

That is interesting. I am glad you have found that the Temporal AA is working for your project and that you have optimized your game in order to implement it.

I have a couple of questions in order to narrow down what is causing that line.

1.) What kind of lights are you using. Are they static/station/static?
2.) If they are stationary or static have you built your lighting yet?
3.) If those are metal materials, do you have a screen reflection capture inside of you scene?
4.) Have you converted your BSP brushes into static meshes?
5.) If so you will need to go to your content browser where you created the mesh. Double click on it and bring up your details panel. On the right side scroll down to the Static Mesh Settings and change the Light Map Resolution from 4 to 64 or 128.

After looking through some of these questions and troubleshoots please let me know what you find and if step five fixes the line.

Looking good for a block out so far keep it up :slight_smile:

Hi !

  1. That one light there is for editing
    pupurposes, so it’ll be removed for
    the actual game.

  2. I did build the lighting and
    geometry with that light there
    though, yes.

  3. They aren’t metal, but concrete,
    however they do have a bit of
    reflectivity to them. I haven’t
    added a screen reflection capture to
    the scene though.

  4. I haven’t converted any of the BSP’s
    into static meshes. I didn’t know
    you could do that. Would that help
    performance wise?

Thanks for the reply!

Hello Hoopera,

I set up a test project with four walls and a ceiling. I then added a point light and a post process volume. I then changed it between TemporalAA and FXAA and built for both. I still do not see that aggressive white line that you see.

1.) I can try and test this on my end on your project. If you would link to a copy of your project in dropbox I can take a look at it.

2.) You can stick with TemporalAA as you have already done the work to optimize your game.

These are the only two things I can think of to do at this point. TemproralAA and FXAA use two different types of Dithering calculations in order to return a value on your screen.

Let me know what you want to do.

I was having the same issue, finally I figured out what was happening. In my case was a problem with de ExponentialHeightFog and the FXAA. Sadly the unique way to solve this issue is removing the fog or using Temporal AA, that right now is quite blurry and expensive…