Strange trailing/motion blur on UE3 style blood and screen effects

I set up a number of camera particles like GOW and the other UE3 games have. A particle spawning sprites right in front of the camera. GOW did this for the blood splatter on the camera for one.

I set it up the same way in my game, with broken glass shards (screen gets shattered), which works fine, however the moment I move my player or camera (whatever movement I do), the particles begin to trail. They lag behind ever so slightly, making it impossible to use these kind of effects.

It is post process related. The particles appear fine when they render on top of the item I am holding, it is only when they render on top of more distant geometry (100 units+ or so) that they begin to trail.

When I typed “show postprocessing” they no longer trail.

I have a post process volume with both motion blur values set to 0.

I tried turning off depth rendering from my material, and any other combination of properties I found but nothing fixes this.

I tried finding ways of controlling what parts of Post Processing is active like in UE3 (inis, post process chain) but none of that is exposed any longer it seems.

I also do not seem to have a way of rendering things in the foreground, after the PP pass? Can I exclude my particle somehow and render it last?

Bug? Another way to get a similar result?

For translucent objects try Material Editor → Details Panel → Translucency → Enable Responsive AA. I forget if this requires Enable Separate Translucency also to be checked. When Responsive AA is enabled for a translucent material, it should reduce the trail.

A screenshot would help. It’s likely TemporalAA (Antialiasing).
Try “show TemporalAA” in the game or use the editor showflags to find out if thats the case.

There is some things you can do to prevent that.

Hi, Yeah tried making a pic of it but wasn’t visible. Needs to be seen in motion.

Show temporalAA however fixes it. Any way to default toggle that off or somehow control it (if possible)? I can’t locate it in the ini files. Thanks.