Strange material glitch or is my graphics card dying?

Hey everyone,

I’ve just started learning ue4 and been experimenting a lot with terrain material generation. This is my current project:

7491e410ab4b24b23d7308689663cf671d0f1df4.png

I am using 4 different 1024x1024 grunge maps to break up the texture tiling on my 4033x4033 terrain, textures are 2k and 4k from the editor starter pack and ue4 open world 2015 demo respectively, also, 3 of the grunge maps are grouped together on top and are mixed into the base terrain texture from World machine. You can see that I am also using another grunge map to further break up 2 of the terrain textures in the “cliff” and “basalt” groupings. Adding that was my last step before I started seeing this (roughly my last step, I think they appeared somewhere within an hour of me adding those bits):

Judging by the splat map, the affected layer is the “basalt”. Removing the grunge map “additive” and recompiling the material does nothing, those blotches still remain. Another thing I should probably mention is that I had to change the Sampler Source parameter for all of my TextureSamples to Shared: Wrap, dunno if that could somehow help explain this.

Could this be my old GTX460 dying? Those garish green and pink colours kind of remind me of when my 1900XT was dying…

EDIT

Changing the Basalt textures for anything else from the starter content makes no difference.

THe first thing I see that could explain it is how you’re handling your global grunge map. You’ve added 1 to each of the initial 3 RGB texture samples, making the range for each channel go from 1-2 rather than 0-1, so your end grunge map your multiplying over the terrain has a potential range from 1 to 3. Also you’re adding the terrain texture sanoke to everything else, also bumping up the top end of that range over 1. So your final base color values are somewhere from 1 to possibly 6 in a worst case scenario.

That is fully undefined territory in this renderer. A base color value of 1,1,1 is perfectly impossibly bright white, so that is likely where your odd color splotches are coming from.

Try removing all those “add 1” nodes on your texture samples. They’re going to be doing very strange things to your end values.

Thing is, that it was working fine with exactly this very same setup somewhere before adding the grunge maps to the proper constituent terrain layers, but I will try your suggestion right now, cheers for the feedback.

EDIT

Ok. This is what I get with the “Add” nodes gone from the “Global Grunge Map”:

And this is what I get with the “Add” node replaced with “Multiply” for the terrain color map merger:

723a6d84e22a6700f568e9e60efef8caf62a67e5.png

Those blotches are still there in both cases.

Think I should try running it on integrated gfx to eliminate the possibility of my card being the culprit.

EDIT

Same with haswell graphics and I found a screenshot from earlier of it what it had looked like before, definitely with the same global grunge map arrangement, but perhaps before mixing in the maps with the high res textures or changing those Sampler Source parameters. Will have to try restore it all back step by step at a time, it’s all well confusing.

Insane…

All the grunge maps removed, all the sampler sources set back to default. The blotching seems to be independent of any LandscapeCoordinate mapping scale parameter values.

What is going on? Any ideas?

EDIT

Deleting “Lava” solves it. That Lava texture’s been there from the very start… yet it glitches out the entire material presumably after some later steps taken, the reversal of which doesn’t eliminate the problem. It’s quite bizarre to say the least.

Restored my initial material arrangement almost one for one to the same as at the issue inception, no glitches so far, so I guess it has somehow resolved itself. Still, any comments as to what might have been causing this are welcome.

And my own guess as to what may have been the cause from some of the document stuff that I’ve been going through:

When using certain combinations of layer blend modes you could end up with black spots all over your Landscape where different layers meet. This problem is especially prevalent when using the LB_HeightBlend mode for multiple Landscape layers. LB_HeightBlend works by modulating the blend factor, or weight, for the layer using the specified height value. When you have multiple layers painted on an area and they all are set to LB_HeightBlend, it is possible that all the layers painted in a particular area will simultaneously have a 0 height value, so the desired blend factor for each layer becomes 0. Because there is no implicit or explicit ordering, the result will be black spots because no layers will have any contribution to that area. The situation is worse when you are blending a Normal map, because it results in a Normal value of (0,0,0) which is not valid and will cause rendering problems with the lighting. The solution to this problem is to use LB_AlphaBlend for one of the layers like in the following example.