Download

Strange Lightin on Static Mesh [Blender]

Hey,
I did a static mesh in Blender

With these .fbx Export Options (in fact I changed the Size to 0.1 and selected the Mesh button)

But I got this strange issue and don’t know what to do. I tried it several times, but now I need your help.
What can I do ?

Barrel_Problem.png

Your UV islands may be too close to gether. Give them a mit more elbow space…
Also try a less cluttered mapping. Just unwrap the barrel sides as one cylinder with one vertical seam.
If that would interfere with your intended texturing, add a second channel and work with that.

Couple of things.

This looks like it’s either a smoothing group issue or you may need to increase the lightmap resolution if you’ve not already.

While the UV layout could use some tweaking the two things I’ve suggested, more than likely the smoothing groups, would be the first place to look.

Let me know.

Tim

I would bet on a bit of everything listed above

  • give your islands a proper margin and don’t use the smart unwrap option in Blender, you have to do your UVs manually if you want them to be good
  • mark the perimeter edges as sharp - that’s the smoothing groups problem solution in Blender
  • increase the lightmap resolution

@KVogler
I gave the UV Islands more space between each other and also tried several other UV-Layouts, sadly there wasn’t any difference.

@Tim Hobson
Neither Edges or Faces as smoothing groups makes a difference. How much increased does the lightmap to be ? At the moment it is 1024.
I tried different UV-Layouts.

@rimau
Hopefully I did it right, but marking the edges as sharp did’nt make a difference.

random question, when you imported it did you use “compute normals” or “import normals” in the settings?, using import normals can mess up smoothing like that even if you set the smoothing groups properly in blender.

also if you want you could upload it and we could take a look at it.

ok 2 things here

  1. size matters, in the blender screen shot i can see the grid , to me that says theres a good chance your using the default size for working, remember that 1 blender unit equals 1 unreal unit , the normal size of the barrel should be around 100 units high
  2. the uv layout needs a lot of work imho, you need to reduce the ammount of seams, a simple barrel like that only needs 3 seams to get a decent uv layout.
    hopefully the pic will show what i mean

Great, thanks for the help :slight_smile:
I will try it out.

No, it still doesn’t work. And I don’t know how to find a solution.

I adjusted the size.

I tried a resolution of 4096p for the 2th UVChannel.

603160bb3a6cae6642827a796885bb296041648f.png

ok upload the blend file + uasset and pm me the link and i’ll have a look to see if i can fix it