Download

Strange light build - blotches

When I build lighting the actor has strange and unique imperfections. I have struggled to be sure that the light map is correct. The map channel is UV channel 2 and looks reasonable. is this information getting used when I build? do I need to set the UV channel somewhere to force channel 2, do I need to redo the map channel? I box unwrapped the UVs using MAX. The original geometry came from Revit.

Can you share a screenshot?

The general workflow for setting up a mesh for lightmaps:

In your 3D software:
-Add a second UV channel which will be used for your lightmap, make UV’s that are not overlapping and fit within the 0-1 UV space
-Export to UE4

In UE4:
-in the Import window, uncheck Generate Lightmap UV’s, if this option is enabled it will copy the UV’s to a new channel and set that as the lightmap UV channel, so if you have your lightmap UV’s already set up then you don’t want this option enabled. Also, it makes it sound like it will do the lightmap UV’s for you, but rather it requires your UV’s to have the seams set up already, it just runs a flattening and packing algorithm with existing UV seams.

You can check to make sure your Lightmap is assigned to your correct UV channel by opening the mesh from the Content Browser and then on the right find the listing for Lightmap Coordinate Index, and make sure it’s assigned correctly. Usually your main textures will be using the first UV channel (index 0) and the lightmap UV’s will use the second channel (index 1)

So, it looks like it had the Generate Lightmap UV’s option enabled, so what you’re looking at is what UE4 tried to generate
The result there is not great, in that there’s too many splits of the mesh which will require a very high resolution lightmap to get a good result.
Also, the settings that you see on the right side there are actually the Build settings–the settings that it used to generate the lightmap UV’s, not the actual lightmap UV’s setting. If you want to change the lightmap resolution or change the lightmap coordinate index then you need to scroll further down to get to those settings.
For something like that if you don’t adjust the UV’s to be better you will need to increase the lightmap resolution to at least 512.