Download

Strange framerate issue in editor

​​​​GPU: 1060 6GB
CPU: I7 7700K @4.2 Ghz
RAM: 32 GB
Windows 10 64 bits
Blank scene runs between 25 and 35 fps (was getting like 150 fps weeks ago)

As reading thousand “low fps” topics, I’ve tryied :
Turn off Nvidia overlay in GeForce Experience
Close all background process
Turn off Windows defender
Update drivers (GPU, motherboard)
Still the same low framerate.
Games are running fine (Witcher 3, Far cry 5, running at 70+ fps)

What I really don’t understand is that GPU visualizer is reporting something like 3ms for rendering while “stat fps” command is reporting something like 33ms :

47988431c56b2ad29cc04ce9e2819b9e516e9369.png
https://forums.unrealengine.com/core/image/gif;base64
​​

Do you have several other editor windows open?

Each window you open takes up rendering time.

BPs, Materials, pretty much any window except the main one costs something.

So if you are working on 3 screens with windows on all 3, that’s already an extended cost to the main scene.

That said.
a 1060 can barely run the editor on “medium” settings, so if you have it all set to epic or cinematic you may want to bump the quality down too.

The games are optimized to run well by both the makers and the card manufacturers.
the editor is not.

Also, if you updated the engine to the preview version, it could also be due to that. It’s a preview. It isn’t meant to do actual work.

Thanks for helping

Nope, no other window opened except the GPU visualizer window (but closing it doesn’t improve the framerate)

Like I said, weeks ago a blank scene was running at ~150FPS on this system (with epic settings). Anyway, switching to low settings doens’t change the framerate at all.
Note that GPU visualizer is reporting ~3ms rendering

Mentioned it to be sure that the issue is editor related only, not an issue related to the machine like overheathing CPU/GPU

It happened on 4.25.3. I tryied with 4.26, same issue.
This problem was reported for years. Was searching for “editor low fps” topics, found lot of them but all those suggestions don’t work (and those topics all ended without answer):

Turn off Nvidia overlay in GeForce Experience
Close all background process
Turn off Windows defender
Update drivers (GPU, motherboard)

Well, because the FPS on the image is 30, and you double checked the things I already mentioned, I’m going to go with:
you must have accidentally enabled FPS limit either by engine/project settings or using ~ to input a command.

To see if thats it, you can probably create a new whatever template peoject. If you get full FPS on those, then you have your answer.

if not, does the FPS ever fluctuate away from 30?

Yes

t.maxfps is at 120.

Nothing else I can think of.

If new projects are all limited I would delete the engine install and re-install it.

Already did it