Strange FOV lines in front of VR camera


Hey guys,

I really looked around the site but couldn’t find anyone with a similar problem. For some time now (unfortunately I can’t pin point when it started to happen first) I have received weird FOV lines in front of my VR camera. They start to appear when I look slightly downwards, then disappear again when I look up. For the last week they have appeared non stop.
(Just upgraded from 4.7.6 to 4.8.3, it happens across various engine versions, and it also happens on the default VR template from mitchemmc right from the start, without any editing)

Camera Setup

The FOV bug appears:

  • independent from camera (switched the cameras in my character BP)

  • independent from overlap events with external volumes, I played it in an empty map and it still persists

  • independent from overlaps with character bound volumes (like collision capsule), because I moved the camera way above the top of my char and it still happens

  • independent from HUD, I tried different HUDs and it happens on the default HUD as well in the exact same way,

  • I have made no changes to the FOV setup whatsoever, my Event Graph doesn’t touch the FOV

  • The only functions that impact my viewport (“Cast to Viewport”) are basic HMD tracking and a health bar widget, but the problem has appeared waaaay before I had implemented the widget

  • Independent from the crosshair, because I removed it including all associated code in the event graph and it still appears

I’m developing based on the latest version of the VR template by mitchemmc

I’m starting to think that it might have something to do with the Screenpercentage & Screen Resolution BPs, but even if I remove those from my level the error persists.

Did/Does anyone have a similar problem? It’s probably a simple solution that I overlooked, but I can’t figure it out …

Thank you so much in advance for all your efforts,


I may or may not have fixed it, at least it doesn’t occur anymore and it might have to do something with this:

In the Camera Details Panel (First Person Camera, or whichever camera is attached to your player character) under Camera Settings, scroll down to the bottom. Press the Arrow to open up an extra tab where it says: “Use Field of View for LOD”. Uncheck this box and the error might go away.

Unfortunately the fix above doesn’t work … this morning it started happening again with the FOV box in the camera settings unchecked…

The reason for this is the positional tracking camera from the rift. whenever you’re inside its range the lines show up if you’re looking at it. I’m unsure of how to get rid of them though.