Strange errors in new levels; Pawn and camera not valid

Hi all,

We’ve been working on a project for quite awhile and have been successfully constructing levels and logic, but recently we’ve been running into some very strange errors. While all of our previously made levels still work fine, when we make new levels using the SAME setup, there are elements that no longer function. Namely our system for switching character and for controlling characters no longer work. I have no idea where to start in solving this issue because as I said, the logic worked and STILL works in our old levels, but now when we make new levels the exact same logic doesn’t work.

I’ve narrowed the issue down as best I can, and using controlling pawns as an example. I built a simple blueprint that should take control of the pawn, using the same base logic that we use for all of our pawn control. This is in a new level, and every time I hit play I get the print string telling me that the pawn is not valid.

Note: This pawn works fine in our older levels, and using a different pawn in this same level yields the same result, and the pawn is “not valid”. Cameras yield similar results, showing as “not valid”.

This problem began when we were using 4.12.5 and upgrading to 4.13.1 has had no effect. We use P4V for source control, if that could make any difference.

Any ideas what would be causing this issue? Let me know what other information I can provide in solving this issue, it’s been a real shot in the foot for development and I’m stumped.

Thanks for reading!