Strange camera rotation with physics based skeletal meshes

Hi there,

I’ve been playing around with the vehicle blueprint, and I wanted to change the default “sedan” model. So I fired up Maya and rigged myself up a little car, and then imported it into UDK. I set it up as a skeletal mesh, and added a simple physics box like so:

I then went and created a blueprint with a skeletal mesh as the root. I went ahead to attach 2 cameras to it:

But when I press simulate, the car falls (as expected), but the cameras switch positions and rotate. Here’s a screenshot of them rotated:

I have no clue what’s going on. I noticed that the x-axis arrow on the collision box is pointed up in my physics asset editor. If I rotate the box so that its Z-axis is up, it still does the same thing. None of this happens if I use the default “sedan” from the vehicle template. Also, nothing rotates if my car has no physics bodies attached to it. It’s only as soon as it has a physics body…

Strange stuff. Hope someone can help :slight_smile:

This is essentially the same issue as

and here:

Ok it looks like I solved it!

In the export options of Blender, I had to set the forward and up axes, but also had to tick off the Apply Transform option. Looks like it works now!

These values may or may not work for your own case. I just played around with them until I got it looking right.

How would this apply to other 3D apps, like 3ds Max?

After a lot of searching I found the answer to this problem, copy paste my answer on another post:

Found a way to keep physics and stop crazy camera rotation: Add two Spring arms, one attached to each other. One will act as a “buffer”" for the rotation (shake).

Mesh > Spring 0 > Spring 1 > Camera

Make sure Spring 0 has no “inherent Pitch/yaw/roll”, while the opposite is true for Spring 1. Also make sure both have a bit of “Arm length”, each can take half of your desired distance. Don’t add any rotation or “collision test” to Spring 0.