Download

Strange bone rotation when using trail controller

Hi everyone,

I am stuck with a weird issue.

I made a model of fish with an armature in Blender 2.8 and exported it using standard fbx export options.

The model works, the basic swimming animations work too, but when I try to add a trail controller to the tail to give some smooth movments, the bones suddenly rotate at 90° from their original position, creating a pikachu-like tail.

I made sure to apply the transformations of rotation and location to both armature and mesh in Blender, and the axis orientation of the model and armature seem to be similar between UE4 and Blender.

Any idea what could cause this issue ? I tried adding this trail controller to some free models of the marketplace and it worked perfectly…

Thank you

3 things.

  1. look up the Abuzu talks for how they managed to make their fish. Its a completely different pathway so you should be aware beforehand.

  2. I would reduce the number of bones a bit. it makes it easier to animate and you would probably never be able to tell end result wise.

  3. could you share the trail controller settings? Without them, we have no idea if you accidentally set it inverted, or if what you have is a simple weight paint issue.

Hi, Thank you for the reply

  1. Yes I saw their talks. It’s very interesting but I have no knowledges and not the required softwares to do this.

  2. My fish is the main character of a mini-game so the amount of bones is required for it. I perfectly understand what you mean if it was for a school of fish that are not the main focuse.

  3. Yes in fact it was a simple stupid thing that I didn’t notice at all. I spent hours trying to fix an issue that was in fact non-existent…
    I completely missed the possibility to switch the axis and even the direction of the chain (picture).

Thanks for your help :smiley: