Strange Android Packaging Error

I’m new to Android development, and I recently decided to use UE4 for it, and I just want to do a quick test package, I installed all the software that it said to and tried to build the First Person stock setup for android, but I’m getting this error:


Any ideas?


Could you please show me what your Android SDK looks like?


Please also show me what your Project Settings > Platforms > Android settings look like for the Minimum SDK Version and the Target SDK Version.


If there’s anything else you want to see, let me know. Thanks!

Try clearing out the first 4 lines in your SDKConfig and show me what happens in your logs.


My other suggestion would be to move your to the C and listing it like it shows up in my initial screenshot.


Here’s the log with the clear SDK lines: https://www…com/s/s66t3dicjke09ot/nosdk.txt?dl=0
And I’ll try moving the a bit later. My UE4 is in the E as well, so not sure if it will do anything.

Your log says at the bottom that it failed with args APP_ABI=“armeabi-v7a” which states that the SDK information is missing (like I thought it would). When you have a , try moving to the C like I have mine set up and show me the logs if it fails.

Let me know! :slight_smile:

Still having errors after move the SDK, heres the log: https://www…com/s/dqi4qhjmvirlgz4/New.txt?dl=0

Did you install the SDK Platform for ()? If you’re not sure, you can check in the Android SDK Manager and you’ll be able to see which API you have installed.

Feel free to upload screenshots of your SDK Manager if you’re unsure.


Not sure if this is the right thing, but here it is:

Use CodeWorks for Android 1R4 u2 and use the standard installation and see if that helps resolve your Android packaging error.

I ran 1R5 yesterday and ran into loads of trouble.


I’m trying to install and getting this:

Thanks for all the help, by the way :slight_smile:

Do you have Administrative Rights on your PC? Make sure you are running everything as Admin as that seems to resolve a lot of access denied troubles.

Try deleting the R11C folder before trying to install again and see if that helps.

Let me know - thanks!

I fixed the problem and installed 1R4U2, and now UE4 is giving me this: https://www…com/s/esevk0icpn6w4da/UpdatedSdk.txt?dl=0

Please make sure that your target Android build matches the API you installed through the SDK Manager. For example, if your target is then you need to make sure that was installed.


I have API 19 I’m pretty sure, and UE4 is set to Android 19, so I don’t know what I’m missing here. Would reinstalling the SDK entirely help?

Open up your Nvidia CodeWorks for Android Component Manager and then select ‘CodeWorks for Android 1R4u2’ and select ‘Standard’. Once you’ve done that, the ‘Next’ button should become an option, so click on ‘Next’ and let that install. Once that’s completed, restart your computer and see if that allows you to package your project.

If it does, it means either you’ve forgotten to install part of the SDK or that part of the SDK that was installed may have been too far ahead of what UE4 supports.

I followed what you said, and got this: https://www…com/s/51735gkjg8ammpr/IDK.txt?dl=0
No idea what’s causing this, and I even checked full instead of standard just to be sure.

Do you have FMOD enabled as a plugin on your project? If so, could you please disable it and try again?

I dont have FMOD, so I dont think that would be it.

I saw ‘FMod’ in your logs, but it’s ‘MFMod’.

Please delete the Intermediate and Saved folders from your project.

Delete the Config files too, if you haven’t changed any of your projects configurations. If you have changed your projects Configurations and the Intermediate and Saved folders do not resolve the issue, consider deleting the Config folder.

Upload your new logs if it fails again.

MainFrameActions: Packaging (Android (All)): BUILD FAILED
MainFrameActions: Packaging (Android (All)): C:\\android-sdk-windows\tools\ant\build.xml:649: The following error occurred while executing this line:
MainFrameActions: Packaging (Android (All)): C:\\android-sdk-windows\tools\ant\build.xml:694: null returned: 1
MainFrameActions: Packaging (Android (All)): Total time: 4 seconds
MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file 'E:\UnReal Projects\MFMod\Intermediate/Android/APK/bin/MFMod-debug.apk'.
MainFrameActions: Packaging (Android (All)): File name: 'E:\UnReal Projects\MFMod\Intermediate/Android/APK/bin/
MainFrameActions: Packaging (Android (All)): MFMod-debug.apk'