Download

Storage Box blueprints?

If I want an item to be craftable at a workstation such as the Smithy or any storage box for that matter, how would I go about doing that? I tried checking all associated blueprints for the smithy and found nothing correlating to items it can craft.

I tried looking in the following files:

EngramEntry_AnvilBench
PrimalItemStructure_AnvilBench
StorageBox_AnvilBench
PrimalInventoryBP_AnvilBench (Here, I tried modifying the elements in the property called “Default Inventory Items” and “Default Engrams”, but this doesn’t seem to affect how the items are shown in smithy while testing.)

Any help is appreciated, thanks.

Its better to craft a new station though.

I tried to follow your tutorial. I got the item blueprint to show up in the the storage box, but I’m not able to craft it. The crafting button does not show up. It shows up as craftable (white background) when I have the required craft items in my player inventory though. So it’s not referencing the items’ inventory, if you get what I’m saying.

What I did was copied the the StorageBox files to my mod: EngramEntry_StorageBox_Large, PrimalInventoryBP_StorageBox_Large, PrimalItemStructure_StorageBox_Large, StorageBox_Large

I renamed them to *****MyBox instead of *****StorageBox_Large

I then followed your tutorial. I noticed that in the StorageBox_MyBox file, there is a component referenced called “PrimalInventoryBP_StorageBox_Large_C1”. I assume this is a subclass of the PrimalInventoryBP_StorageBox_Large and it’s referencing the core file storage box inventory and not PrimalInventoryBP_MyBox. I tried to change this, but my copied file isn’t showing up as an option to change to.

Can you help me troubleshoot? Thanks.

Anything that has _C# appended to it generally refers to an instance of whatever it’s name is.

Did you change the crafting inventory requirement on your item to match the new structure?

-WM

Yes I changed “Crafting Requires Inventory Component” to PrimalInventoryBP_MyBox. I followed everything in the tutorial but as I said I’ve used my own version of the large storage box instead.

But as I said, I think it might have something to do with the fact that the StorageBox_MyBox item itself contains a reference to the old StorageBox_Large as per the picture below:

primalinventorybp_storagebox.png

I tried clicking on the “Add Component” dropdown, but can’t find the PrimalInventoryBP_MyBox.

Yes, that is an incorrect reference as that is still pointing to the original.

Can you delete that component, compile, and in add component search for inventory and see if yours shows up then?

Otherwise, you’re sure the inventory file is in your mod folder?

-WM

It finally worked!

That wasn’t the root of the problem but it was close enough. Deleting and recompiling seem to make it appear. However, that didn’t solve the problem. The problem was because I used the StorageBox blueprint instead of a smithy which does not come with the “Allow Remote Crafting” property enabled. I had to enable that in the PrimalInventoryBP (PS changing it in the instance doesn’t work, the change needs to be done in the blueprint itself.)

Thanks for all your help! Hopefully this will help other people too.