Download

Stopping the editor from using so much CPU when idle

The UE4.1 Editor uses significant CPU even when nothing is happening.

This makes my machine heat up and means I get < 60 minutes of battery life vs a more normal 3-4hrs.

It also means my machine is effectively DOSed if I need to use some other app like Photoshop

Is this a known issue? Is there some setting I can click “pause when paused”?

I expect high CPU usage when playing the game. I don’t expect that when in the editor when the game is not running. In fact in the screenshot the editor is even minimized and yet it’s still using a ton of CPU

Un-tick realtime from viewport and also go into the task manager processes and set affinity to use 1 CPU.

Reverse when you wish to re-use it fully.