Stopping PIE lags when Project/Editor Settings window is open

issue occurs on 4.14.2 and 4.14.3

System specs:

Windows 7 64 (Enterprise - latest updates)


GTX 670

1638MB RAM

Repro steps:

  1. Create and launch a new Third Person template (likely any type of template/project is OK).

  2. After the project loads up, go to “Edit” ( top left of the main Map window) and click on “Project Settings”.

  3. Click “Play” to PIE once the Project Settings window becomes visible. (Leave the Project Settings window open.)

  4. Once PIE becomes functional, click “Stop” to stop PIE.

Result: It takes approx. 5 minutes for the user to regain control of UE4.
(With the Editor Preferences window open it takes over 15 minutes to regain control of the editor.)


  • Depending on the size of the project the time it takes for the user to regain control over the editor (or UE4 in general) will vary. The bigger the project, the longer it takes.

  • It takes longer for the user to regain control of UE4 when the Editor Settings/preferences window is up, compared to when the Project settings window is up.

  • I don’t think problem occurred in 4.12


Close the “Project Settings” or “Editor Preferences” windows before PIE.

Hi ,

I was not able to reproduce issue but I want make sure I’m following your steps correctly:

  1. When you have the Project Settings and Editor Preferences open, are they in their own floating windows or docked as tabs in the Editor?
  2. When you’re Playing in Editor (PIE) are you in the Selected Viewport, Mobile Preview, or New Editor Window?
  3. Are you working with one monitor or two or more monitiors?

Please respond with info and we will continue to investigate.



Hello ,

As far as I know I haven’t made any changes to the default editor settings (regarding how new windows open, PIE mode designation…)

  1. When I click on Project Settings or Editor Preferences from the “Edit” menu, they each open in their own floating window. They are not docked.

  2. No windows are open except for the main “Level” Window w/ viewport and the Project settings or Editor Preferences window. With that said, I’m pretty sure I’m in the “Selected Viewport”. Here’s a pic of what it looks like.

  1. 2 monitors (apologies for not mentioning it sooner)

I am still unable to reproduce bug… please post your dxdiag. In the meantime, here are some things you can do to increase video performance:

  1. Drag any floating Windows to the upper most tab to dock them. It takes more Ram to render floating Windows
  2. Close other background programs
  3. Decrease Engine Scalability Settings

  1. Un-select “Real Time”

Let me know if any of the above help resolve your issue. Make sure your system has at least 8GB Ram (Preferably 16GB) and that you have installed the latest drivers for your GPU: GTX 670.

Hey .,
Thanks a lot for the prompt response and clear countermeasures. I’ll start with updating the GPU driver (it’s almost 3 months old). I attached the [dxdiag][1]. I know there’s 16gb ram in machine, but I’d assume it’s considerably slow.

Here’s a new [dxdiag][2] after installing the latest driver for the 670 and restarting.

Here’re some pics of the mem usage with it FLOATING





Seems I still have plenty of ram.

Updating the driver didn’t seem to make much difference. Strangely though, the first time I tried stopping it with the project settings window floating, I got control within about 3.5 minutes. With it docked, I didn’t get control after 5 minutes, so I just force killed the editor.

(Trying it again, just for good measure, the memory is a little higher for floating now.)

I’ll try messing with the other settings now.

Jsyk, isn’t really a big deal issue. It’s just something I thought wasn’t a problem before, that’s why I posted it. I can easily avoid problem so long as I kill project settings/editor preferences before launching PIE.

Hi ,

Your dxdiag shows you should have plenty of ram and video ram + processor speed to run UE4 without lagging regardless of floating windows. However, in order to address a bug, we have to be able to reproduce it on our which we have not been able to do in case.

That said, the UE4.15 Preview is scheduled to launch today if you want to see if the issue persists in that version. Also, if you haven’t already, you could try installing UE4.13 to see if the lagging occurred in previous versions of the engine. If you choose to do either, please let us know the results.



Thanks a ton for the speedy followups. The last time I mucked with opening the project settings tab while working in the editor and PIEing was on 4.12. It definitely wasn’t a problem then.

I just gave 4.13.2 (which had been installed previously) a try. (Unlike 4.14.3, the project settings window opens virtually immediately after clicking on the selection, unlike on 4.14.3 where it takes about 8-10 seconds to appear.) issue does not happen on 4.13.2. I tried it at least 3 times.

Note that I tried out on my own project. The version of the project launched on 4.14.3 has more content (textures, 3 extra skeletal meshes, among some other data, some blueprint logic additions/modifications) than that of the 4.13.2 one.

I thought maybe there’s something I’m doing in blueprints that’s making it lag up, but it shouldn’t matter considering even a fresh 3rd person template takes forever to shutdown from PIE in 4.14.2/3.

If there isn’t a settings file for 4.14.3 I can supply you with, I’ll try 4.15 when it releases and update with the results.

Thanks again and sorry for the long post.

is no longer an issue on 4.15 preview 2.
Thanks a lot for the help and tips, !