Download

Stop SetActorLocation object coming near ?

I did see a video on Youtube about this problem but forgotten what I searched for. Using SetActorLocation the actor keeps coming nearer to the camera, how can I stop this ?

I’m slightly sure it was to do with ignoring self, but there’s no option for that.

Am I able to create a trace channel so it can only hit the floor ?

Edit: I added the trace channel which works fine. However I’m also doing a line trace from the player camera to the floor using the “Line Trace for Objects”, I’ve set up the trace but how can I create a custom object type list or add a type to the list ?