Stop Construction script updating when i move object

Whenever I move my blueprint actor within my 3d scene, the construction script (which i have made to randomly spawn meshes) updates. This causes lag.
Can I stop it updating like this, or make it update less often?

Yes, I cant remember the exact tick box and I dont have unreal open but there is a setting in the details panel. Its something to do with running constructions script on transform

I cant see any such tick-box. What else might it be called?

In the actors class settings disable “Run Construction Script On Drag”

If it doesn’t get updated on drag, how else can Construction script run in the Editor?

Thanks so much The Agent. Its works fine. However, it would be even better if I could change the speed at which the construction script runs when I drag the actor. Is that possible?