Download

Stop compiling TUTORIALS!

Every two seconds, any change at all and you start compiling the tutorials.
It hangs on the tutorials for 20 minutes.

Its the same with VR, im not making a VR game, I DONT NEED F-ING TUTORIALS AND I DONT NEED F-ING VR, and I dont need them cooked on any change.

Stop compiling TUTORIALS…

Stop compiling TUTORIALS…

Your engine is always building UNRELATED NONSENSE!
Dont even respond, this has been going on since UE3.

And while your at it, remove all the padding, unbelievable amount of padding, Rip off adobe already, make something slim and efficient.

Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…Stop compiling TUTORIALS…

Hey @Drenchedpuppet sounds like you’re building the entire solution (which is unfortunately the default in Visual Studio), rather than just the startup project. One solution is to use UnrealVS and map F7 (or whatever key you trigger a build with) to UnrealVS.BuildStartUpProject. Here’s how you can just build the project in VS: Building Unreal Engine from Source | Unreal Engine Documentation

Edit: You’ll need to grab UnrealVS from Engine\Extras\UnrealVS\VS2015 for that.

It’s really a Microsoft default settings decision, not a choice on our part, but the UnrealVS.BuildStartUpProject setup is our workaround for it.

Let me know if that helps