Stop camera movement when aiming

I’m having a bit of a problem where my character and camera move too much when aiming, because of the idle animation, as shown in the video i took.
Is there any way i can stop this? Or do I have to use another animation altogether?
Thanks in advance

Hey @ImDomo,
How do you have your blueprints set up? You can adjust the rate of the movement there.
I hope this can help!
-Zen

Hey @ImDomo!

If your camera is following your idle, it may be best to do an upper body aim animation and layer that animation with what you currently have. Check out this non-Epic affiliated video for setting up layered animation:

I hope the above is the solution you need.

Where can i do that?

I wanted to edit the idle animation so it would stay still in all of the frames but i seem to be having a hard time doing that.
Any suggestions? I’m a beginner when it comes to animation stuff

Hey @ImDomo,

What you want to do in that case is create a pose asset. Here is the documentation on how to do so:

I hope the above is what you need to complete your effect.

That’s it! Thank you so much!