Stop blueprint from looking for deleted asset!

This problem has been afflicting me since I started using Unreal Engine nearly a year ago:

  • Blueprints A, B, and C references Blueprint Z.
  • We remove all references to Blueprint Z. All references. We save everything. We compile everything. In Blueprint A, B, and C, and anywhere else there are no more references to Blueprint Z. Searching for Blueprint Z globally only shows Blueprint Z itself.
  • We delete Blueprint Z.
  • Searching for Blueprint Z globally turns up nothing. NOTHING! It must be gone! Except…

Forevermore, every time the project starts up we get warnings like:

/Game/BlueprintA : Can't find file for asset. /Game/BlueprintZ
/Game/BlueprintB : Can't find file for asset. /Game/BlueprintZ
/Game/BlueprintC : Can't find file for asset. /Game/BlueprintZ

And when the project builds, we get warnings like:

UE4Editor-Cmd: [timestamp][   0]LogLinker:Warning: Can't find file /Game/BlueprintZ
etc. etc.

There are literally dozens of similar warnings about this file or that file not being able to find or load BlueprintZ.

How do you fix this???

In your Content’s panel, Right click Content and Fix Redirectors…

Hope this helps :slight_smile:


Try the following

  • delete most of /saved/, except config, screenshots and save game
  • delete /intermediate/, /build/, /binaries/
  • restart project
  • try packaging, then cook then package again.

That looked so promising! Alas, I did that on the Content folder AND on every subfolder, saved the project, closed it, and then opened it back up. Unfortunately, it had no effect. Same loading warnings. Same warnings during packaging. I’m beginning to fear that there is no way to fix this other than recreating the blueprints. :frowning:

Followed your instructions exactly. No effect. :frowning:

By the way, in the cooking stage ends like this: (notice how the first line in this snippet is contradicted by the rest of the lines).

MainFrameActions: Cooking (Mac): UE4Editor: [2016.04.12-04.07.41:149][  0]LogInit:Display: Failure - 12 error(s), 114 warning(s)
MainFrameActions: Cooking (Mac): UE4Editor: [2016.04.12-04.07.41:149][  0]LogInit:Display: 
MainFrameActions: Cooking (Mac): UE4Editor: Execution of commandlet took:  17.04 seconds
MainFrameActions: Cooking (Mac): CommandUtils.Run: Run: Took 24.465174s to run UE4Editor, ExitCode=0
MainFrameActions: Cooking (Mac): Project.Cook: ********** COOK COMMAND COMPLETED **********
MainFrameActions: Cooking (Mac): Project.Package: ********** PACKAGE COMMAND STARTED **********
MainFrameActions: Cooking (Mac): Project.Package: ********** PACKAGE COMMAND COMPLETED **********
MainFrameActions: Cooking (Mac): Automation.Execute: BUILD SUCCESSFUL
MainFrameActions: Cooking (Mac): Program.Main: AutomationTool exiting with ExitCode=0 (Success)
MainFrameActions: Cooking (Mac): Domain_ProcessExit

Sorry I’m out of ideas! This never has happened to me before.

Dang. Looks like I’ll be recreating the blueprints.

might be worth checking the folders in windows explorer to make sure there arnt any remnants of files that unreal isn’t seeing.

I don’t see anything amiss in the actual folders.

Recreating about 6 blueprints has solved half my errors. One error was solved by deleting a float it claimed it couldn’t find and then recreating that float in the exact same place, same name, same value. Dang blueprint corruption.

I expect I’ll keep recreating the blueprints until my errors are gone. Very lousy solution. Not impressed, Epic.