Still getting default free fly cam even after creating custom game mode and character blueprint

I decided to create a first person game mode from scratch using blueprint. After setting the input and everything, when I press play, I still get spawned as the free fly camera even though I set the Default GameMode and Default Pawn Class to my Custom Game Mode and Custom Character Blueprint, respectively, in the Project Settings.

What gives?

Wish I could take this back. I figured it out. Just had to change Auto possess player to “Player 0” so that priority would be given to my pawn over the Free fly cam. Sorry and thanks.