Download

STEP File Importing with holes in the model

Hello,

I am working on importing a STEP file from a CAD Model into Unreal Engine 4 and the left top part of my model continuously is missing. This seems to be an issue unique to the Unreal Engine as I imported the same model into VRed Pro without any issues.

Please help if you can or direct me to a discussion where this issue is resolved.

Note: I have tried the object options by right clicking on the model and going to Datasmith/Retesellate and it did not fix the issue.

Those kinds of files can be hit or miss to convert to a mesh, which is what UE4 has to do to use them. What program is it originally from? You might try exporting from a different program

Thanks for the quick response! I will check and see what program it was exported from, this is a collaborative project that I am working on with another developer. We are interested in using Unreal for future PD projects and testing the waters with this file.

So I have tried exporting it again from fusion 360 and I still have the same issues. Do you have any suggestions? If it helps it is happening in two separate CAD files that I am importing as the first is iges and the second is a STEP file.

I tried exporting them from fusion 360 and the same issues came up. I did happen to import them into 3DS Max and successfully fix things in that program but unfortunately that isn’t going to be a long term solution as my end goal is to take CAD data from multiple design programs and import them to Unreal for review.

It’s from fusion 360. I was able to fix the issue importing into 3ds max but unfortunately that isn’t a long term fix as my plan is to use Unreal only for the data import cycle. I wish Blender allowed for importing CAD models, I could possibly fix it in there too.