Download

Steamcmd Uploading

Hi folks

Anytime i try to upload with steamcmd i get this error. I’ve tried portforwarding (27000-27050?), disabling firewall & AV & had a good search with google but cant seem to fix it. Anyone here have any ideas?
20681b4bf44e6cdfb4adfca002eb6d3934b51c9c.jpeg

Hmmm, first time seeing this one personally. Think I found the answer to it already though:

https://developer.valvesoftware.com/wiki/SteamCMD

Hit ctrl+f once you open that link while on that page, and type in port, and go through the 11 instances of port till you find the section where it says “Login Failure: No Connection”, or quicker yet, just type in the search box when you hit ctrl+f “Login Failure: No Connection”.

Try the steps there and also try port forwarding those ports they list

Wowsers! I had already tried that (was the first hit no matter what variations of whatever i tried to search for :D). But i deleted my ports and redone them and this time it worked. Whether i had made a mistake previously, or somthing else has changed and fixed it im not sure - but thanks, it seems to be working now :slight_smile:

Port forwarding is very finicky at times depending on the router in my experiences >.<

Glad to hear its resolved now! Happy modding good sir. Closing thread since problem is resolved :wink:

Ok I’m getting the same issue again today - with no changes to Ports/Router/IP since it was working.

Does anyone else have any idea what might cause this, or any possible solutions?

Hmmm, do you have a dynamic IP? or static? And also, do you have any firewalls on? (I know you mentioned it being off, but even when they are some of them will still actually have a default firewall enabled). Either way, I’d port forward there too just to be sure.

Static IP, i double checked that when it stopped working again today. And firewall was on when it was actually working yesterday, I’ve tried taking it down again but not having any luck - Ill try adding the ports to firewall as well now

Very strange that it is happening at random like that. I can really only speculate at what is causing this at the moment >.<

Are you by chance logged into steam anywhere else when trying to upload? Also can you try using something else to upload it just for the sake of seeing if its steamcmd at fault. You could even use the old standalone tool if need be to test if you have problems with the built in one.

My tablet is usually signed in actually - never considered that! Just recooking my mod then i will try it with stand alone cmd.

What else do mean i could try to use to see if its steamcmd at fault?

check here might fix ur problem

Tried all of the above now and still no luck…

\SteamLibrary\steamapps\common\ARKDevKit\Projects\ShooterGame\Saved\Mods.db

Find the section for your Map/Mod after you’ve attempted an upload:

{
“ModDir”: “GenericMod”,
“Maps”: “GenericMod”,
“Title”: “The Lost World (Updated v188 fixed!)”,
“Description”: "Install and run this mod to play on the ARK Island with only primitive-tier technology! ",
“PreviewImage”: “C:/Users/Administrator/Desktop/TheLostWorld.png”,
“Visibility”: “Public”,
“ChangeNotes”: “”,
“ItemSeamId”: “YOUR WORKSHOP ID”
},

then go to

ARKDevKit\ModTools\ModConfigs open ur vdf"

“workshopitem”
{
“appid” “346110”
“contentfolder” “F:\Steam\steamapps\common\ARKDevKit\ModTools\Output\TestMod\CookedMods\TestMod”
“previewfile” “F:\Steam\steamapps\common\ARKDevKit\ModTools\Output\TestMod\CookedMods\TestMod\preview.jpg”
“visibility” “2”
“title” “Test Mod”
“description” “Test”
“changenote” “”
“publishedfileid” “Your Mod id”
}

open steam cmd make sure u login and grant access to steamguard or turn steamguard off (i dont recommend this but i have mine off) then goto ARKDevKit\ModTools\SteamCMD

and

1: login username

2: password

3: donno about steamguard but goes here edit if u still dont figure it out

4: workshop_build_item “Full path to your VDF file”

5: quit

try that

Thanks but I’ve tried it that way also, i get the same results as is the screenshot when it hits ‘Uploading Content’

Done a bit more testing and it seems the issue, is specific to my mod - I managed to upload a blank test mod with no problems at all.

Anyone know what might cause this?

i donno what ur mod does so i really cant say lol

It adds additional NPC entries, remaps spawn points and adds new saddle engrams. I don’t think its an issue with what the mod does (as i never had any issues updating it before) - more likely something has become corrupt somewhere when switching to Epic Games Dev Kit, and i have no idea what.

Is your mod description super long?

Nah the amount of times ive trued it I got sick of copy pasting it so have just been making it a couple of letters while I test it.

Ive started making a `new’ mod (copying the old files into new folder and re linking them all) inital tests seem to be working but it’s going to take forever

It could possibly be something corrupted on transfer, but for it to cause that kind of behavior would be very strange and illogical. It’s very odd that you can upload another mod okay. Are you sure it wasn’t just a random stroke of luck at the time?

“What else do mean i could try to use to see if its steamcmd at fault?” Try using the uploader/cooker located in your ARKDevKit folder, then Modtools, it’s located inside of there. Try using that and let me know if the same problem still occurs.

NOTE: Please do the above step. From what I was just told, steamcmd (which is written by Valve, not Wildcard) is acting up, and if you use the stickied ADK Launcher to upload or the standalone tool I mentioned above, you should have luck

At this point I’m fairly clueless as to what would cause this behavior other than networking things & steamCMD being lame

Thanks for your help, im away from home until the end of the week but I’ll try it when I’m back.

And I tried two different uploads, one was just the generic mod & then tried some files copied from the mod that doesnt work and both uploaded first time with no issue. I did then try my original mod afterwards but it still didnt work.

I agree It does seem strange if it would corrupt during the dev kit transfer because you’ll remember when I started this thread that I did manage to update it one time in between it not working. The only other thing that I changed were the mods.db & the .vdf - but I made back up of both before editing and have tried restoring the originals and still wont work.