Download

Steam Workshop Upload stuck at "Loading Steam API"

Hi there,

I’ve been trying ever since the first Dev Kit was released, and now at v190.0.
The upload process keeps getting stuck at the exact same spot, as the title says, “Loading Steam API”.

First I would normally cook the mod, get the successfully cooked notification, then upload.
Once I hit upload and enter my steam user/pass, it starts loading.
Soon afterwards I’d get the error mentioned above.

Here are some screenshots.

2feb2fb494fa97cd0438b2ca537eb90d7be8a47f.png

daa9fb67248531ef88f0f1da7862fc500d29c24c.png

You need to start steamcmd and login username password, then when promted enter your code (found in your email) then try to upload again and it should work

^ this. It’s steamguard preventing you from uploading without first authorizing it on steamcmd.

Thank you guys for the replies.
I got SteamCMD and downloaded following the Steam/Valve instructions.
Did everything such as the installation, closed it and re-ran it using the cmd menu.
Logged into my account, authorized, got the “license…OK” thing, all done.

Then I went back to the Dev-Kit, cooked, uploaded, still stops at that exact same spot.
There’s a video by one of the ARK Devs saying that the SteamCMD should pop-up on its’ own, but it doesn’t do that for me.
Here’s the video: https://youtu.be/vG4-yrUH9d0?t=9m28s

Thanks ahead of time for your help.

Heads up, you can always just manually disable SteamGuard before uploading via inside of Steam by going to your settings, and then you don’t have to deal with the authentication of it.

Also you do not need to download steamcmd. It comes with the Dev Kit. If you navigate to your ModTools folder there is a SteamCMD folder there. That is where you want to run it from to authenticate it. Basically just do the following:

>login username
>password (when requested)

>(it will say something here about steamguard. Grab the code from your email, and then type it in where it asks you for it in SteamCMD)

>exit (and now you are done)

EDIT: Nevermind the question below, I just had to log onto my Steam Account via the web.
Thanks!

Thank you for that pointer, I didn’t know it was there.
Using the SteamCMD.exe file within that folder you pointed me to actually worked.

I finally got it “uploaded” and got the success message.
Now the problem is…
When I click on “View Item on Steam Workshop”
I get this message on the web browser:

"Sorry!
An error was encountered while processing your request:

That item does not exist. It may have been removed by the author."

I do have the mod set to hidden for now, just to test it out first.
Does this mean I can’t see it for that reason of it being hidden?

I tested the mod all I could within the UE Workshop and it worked 100%.

Hmmm, sounds like it’s not cooking out correctly/uploading correctly to the workshop. That generally happens when the workshop item was not uploaded correctly or had an error. Check your upload log and make sure no errors were stated, and also check your cooked mod folder and MANUALLY check to see if everything was cooked out correctly. I have a feeling they didn’t.

Also to clarify, you should be able to see the mod just fine set as hidden.