Steam voice chat stops working after server travel

I had several Steam multiplayer projects in 4.14 that were using voice chat and worked correctly. After upgrading to 4.15, voice chat only works in the lobby and cuts out after server travel to a new map.

Hey BlackRang666,

Would you mind providing an example of your method for server travel? Are you working in C++ or blueprints?

I got the same problem. I think is the “ServerTravel” Command make it happen.
My ue version is 4.14.
working in c++

If either of you can provide a detailed list of repro steps, or a simplified test project that showcases the issue, please let me know, as I’ve been unable to reproduce this in my testing thus far.


I have a test network project. and how can i show it for u?

I am having this exact problem on 4.15.1 and have been debugging it for the last couple days. Voice works until seamless servertravel and then doesn’t work on the new map. I am calling RestartGame but it calls ServerTravel under the covers.

One thing I did notice in the logs for one of my clients only, is the following

[2017.03.31-03.29.36:399][825]LogVoiceDecode:Warning: SubmitRemoteVoiceData: DecompressVoice failure: VoiceResult: '1' k_EVoiceResultNotInitialized (Voice Not Initialized)

@BlackRang666 @wuchuan are either of you getting this warning in the logs after travel?

Edit: I guess I would see a bunch of these warnings, and not just a single one. So it must not be the cause of voice not working. hmm :frowning:

Note: I am using a dedicated server

You can upload it to Dropbox or Google Drive and pm me a download link through the forums:

Are you using seamless travel?

This is my test project,TKS!!!


Just wanted to give this a quick bump. I have been having the same issue. Voice works fine in our lobby, and after the first server travel, it still works fine for the Listen Server and all Clients, but then after ServerTraveling again, the Listen Server can no longer hear Clients, but the Clients can hear everyone. I have tried to debug this issue, but as far as I can tell, audio data is being sent both ways, and on the ListenServer, audio data is even being submitted into the audio buffer, but still, no voice can be heard. I cannot determine if the audio data being submitted into the audio buffer is silence, though…

Will continue to look into this.

EDIT: Wrongly posted this as an answer, my mistake, and yes, I am using seamless travel

Thanks for the project. I noticed that you’re using the Advanced Sessions plugin in your project. Are you able to reproduce the issue without the use of that plugin? We are unable to create ticket for an issue that relates to a project containing a plugin that could be affecting behavior.

If anyone can provide a plugin-free example, or a reliable set of repro steps I can continue to investigate.

I’m not using Advanced Sessions or any plugins at all. So it’s not related to that. All you should really have to do to reproduce is change ShooterGame’s subsystem to steam, enable voice, and test.

Add an Execute Console Command node. Set it to “servertravel yourmappath” Call that. Voice chat stops working.

Were you able to replicate this? Did you submit this problem to the engine team?

I requested a test project from you, which was never followed up on. On my end, I haven’t been able to reproduce this issue. It’s possible I overlooked a step somewhere along the way, which is why I requested your test project so I can take a closer look and get a ticket entered. Please provide that information so I can continue investigating.


“If either of you can provide a detailed list of repro steps, or a simplified test project that showcases the issue” You did not request a test project. You requested a test project or repro steps. You were given repro steps. Please try to be clear with what you are asking in the future. I will now try to make a test project for you, since you were unable to do so.

Thanks, here’s a base project that you can modify if you’d like if that is easier. It contains a basic voice chat system that should be functioning and uses the Steam OSS. Hold shift to activate Push to Talk. link text

I am also having the same issue, has anyone figured out a solution?

Hey everyone,

Unfortunately, at this time there is not a known solution for this. After several attempts, we have been unable to reproduce the issue internally. We are currently awaiting a repro project, but if anyone else is able to provide one that clearly showcases the issue, that would be great.

I am marking this topic as resolved for tracking purposes in the meantime, but please feel free to leave a comment to reopen the thread at any time once a repro project is created.

Thank you

Hey erebel55,

Yeah, I’ve tried both with and without push to talk. I’m sure there’s something somewhere that I’m missing as far as getting the issue to reproduce, as I know several users are experiencing the error. Any information you can provide as far as how we can reproduce this is helpful, but at this point a test project would be most helpful, as none of our previous attempts have shown the issue.