Steam using Mac

Currently I have added steam online subsystem to windows and it works fine.

I can join host and join games that are currently hosted on windows…

But to add a game to Steam on mac, I have to package it first. And I get the following warning when I package the game for Mac

LogOnline:Warning: STEAM: Steam SDK 1.32 libraries not present at     or failed to load!

And when I add the packaged game to steam through the option of adding Non-Steam game, the game is not detect steam subsystem.

I am using appid 480 SpaceWars but there is no reference of SpaceWars on Mac.

On Windows version of UE I don’t have Steamworks libraries for Mac, are you sure you have them?

Nope I don’t think I have installed steam either in windows or MAC.

Not install steam…you need libraries to be able to connect to steamworks. They are under 4.x/Binaries/ThirdParty/Steamworks/Steamv…/ do you have libraries for steam on mac?

Hi envenger,

Please make sure you the following directory is present:

UnrealEngine>[EngineVersion]>Engine>Source>Third Party>Steamworks

If it is not, are you Building from Source or accessing the editor through the Launcher?

Please respond with this information. -Thanks,

Okay we made some progress with the issue, but the issue is still present.

So we made the steam API work on Mac bu it cant join or host games that can be joined. As a test, we downloaded the multiplayerhsootout from the marketplace and that couldnt join or host games either.

But I could very well see other games that were hosted from windows on a windows device.

And in the steam pop-up, I could see the steam player is playing the Space Wars game but hosting or joining was no possible.

We are launching the game through the Stand Alone game on PIE on Mac. The windows version is the source version while the Mac version is the launcher version.

And while packaging on Mac, it says Steam API disabled even though in the standalone game(On PIE) the steam API works.

So, if I understand you correctly, the initial issue is resolved but you are not able to join or host games on a Mac, so one of the following is the issue you are trying to resolve:

  1. If you are testing two instances of the same packaged game on the same Mac, this is broken and will not work as of UE4.10. This is a known bug and is currently being worked on.

  2. If you are testing two or more instances of the same packaged game on two or more different Macs, this should work. If not, we will continue to investigate.

  3. If you are trying to host from a Mac and join from a PC or host from a PC and join from a Mac, this is crossing platforms and is an entirely different issue altogether and would require a separate AnswerHub post and the solution would be rather intricate.

Please clarify which, if any, of these scenarios describes your issue.

I found out the steam works file was not in the correct place so I put them in appropriate directory. And steam was being recognized while playing standalone game while in the editor.

But while packaging them it was still saying STEAM API disabled.

While playing in Standalone(while in editor) even thought the steam API is visible, the the issue 2 and 3 are happening.

It can neither join nor host steam games both to windows and other mac.

I tested scenario 2 above (Mac host/Join on separate Mac) using the Shooter Game. Please try testing with the shooter game and see if you get it to work. In order for Steam to recognize the executable, I had to move it to the Applications folder. Once there, I could select it in ADDAGAME>“Add A Non-Steam Game”

Hi evenger,

Since we have not heard back from you in a few days, we are closing this post for tracking purposes. However, if you are still not able to host or join a game when testing two or more instances of the same packaged game on two or more different Macs please reply and let us know if you were able to accomplish this with the Shooter Game.

*Note, I had an issue with the buttons functioning properly, but clicking anywhere on the background, then selecting the buttons allowed them to function even though they were “grayed out” initially.


I’m having problems getting my project, which runs on Steam Online Subsystem, to work on Mac (it can’t find any hosted sessions), but it works fine over 2 Windows PC. I made the changes in DefaultEngine.ini and added it to Steam as well. I think I must be missing a key set up for Mac since it works on PC, could you walk me through what is needed to have Steam multiplayer working for Mac or share a project that works for 2 Macs?