Download

Steam Subsystem not working - LoadSubsystemModule([Steam]) failed - 4.26

  • ue 4.26 or 4.26.1
  • Create new Project (any template, I have tried multiple types)
  • Add to .ini (have tried multiple versions of this, e.g. bEnabled=true/false,etc.):

[/Script/Engine.GameEngine]
+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam

[OnlineSubsystemSteam]
bEnabled=false
SteamDevAppId=480
SteamAppId=480
bVACEnabled=000000

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

  • Add Steam Online Subsystem plugins to project
  • At this point, it seems like its supposed to work for other people in more recent videos and instructions but I get a:

LogPlayLevel: Warning: LogOnline: Warning: OSS: TryLoadSubsystemAndSetDefault: LoadSubsystemModule([Steam]) failed

  • I have also tried adding in the .dll files from my steam folder to the appropriate folders, although recent videos I’ve seen do not show this step. Doesn’t seem to make any difference in 4.26

[HR][/HR] [HR][/HR]
I have gotten Steam to work before in the past using 4.24. Trying the same steps in 4.24 now gives this same error.
It seems like 4.25 still (same as last time I tried) freezes up with Steam added.

What am I missing?

I feel like I always waste so much time figuring out how to get Steam to work lol

1 Like

I started working on this as well and was having similar issues in the logs.

Have you tried a build of your project with steam enabled to see if it starts and brings up the interface?

The UE tutorials say you can do this with a standalone launched from the scene, but I have not had this success in 4.26

Do you have all the libraries?

Oh yes, and you have to remember to choose the plugins from the plugin menu for Online Subsystem Steam at the very least.

Yes, tried both with and without.