Steam Setup Utility

Hey Garner. We’ve tried using the tool and managed to get the Steam Overlay working. Weird thing though is that the create session BP node now only works when I play the game as a standalone. When I play it in an editor window or package it the create session BP node always fails. Any idea on why this is the case? We’re using Steamworks SDK v1.30 and also applied the 1.32 clobber fix based on your video.

yea man gotta say no matter what I do, I still get

Followed step by step, looked at every steam tutorials I can find. All the files are where they should be and the ini’s are edited,steam open. Still nothing. Used Source and Binary 4.7.6.

Hey Garner, thanks for all the hard work you’ve put into this. I came across this app after I had already integrated Steam into our game. We are Greenlit, have an AppID and everything and we can connect to one another’s games over the network. The problem we’re having now is that we are completely in the dark about how to access stats data from steam. What we would like to do is be able to store all of a user’s information on Steam’s servers so the information is persistent across whatever platforms the user is playing the game. We are also building the entire game in Blueprints, so I know we are limited in overall functionality.

I guess my question is whether or not there is a way to access the stats through blueprints that are stored on Steam so we can read/write to them, and, if so, does running your application help set that up for us, or is there something else we need to do?

Thanks again for your help!

Chad

I’m a NON-programmer. My project is Blueprint based.
When I hit SETUP, I get this:


Setting up Steam Now

Setting up DefaultEngine.ini config file
Configuring UE4BuildConfiguration.cs to include steam version
Can’t find path to UE4BuildConfiguration.cs

Completed Steam Setup!

Can someone please tell me how to fix this?
Also: do I have to use Visual Studio for this? In the procedure you say stuff like open unreal source, clean and rebuild - is that something I have to do? Again, I’m not a programmer but also I’m not an idiot. If someone could explain how to set this up in layman’s terms, that would be much appreciated!

Sorry to bump this, but it’s really important for me.

Right Click on your .uproject file in Windows Explorer and say “Generate Visual Studio Files” (not sure of the exact wording) … this should create the files that you need. I haven’t tried this myself … but I am assuming it has something to do with this.

Make sure you have checked this as well … it may give you some insight.

Steam, Using the Steam SDK During Development

Yes you need visual studio … if you are not comfortable then I suggest you find a programmer who can help you set up the project for you properly.

When I try that, it says “This project does not have any source code. You need to add C++ source files to the project from the Editor before you can generate project files.”

Is there anyone who can please just explain these simple steps in simple words for people like me who have no programming knowledge?
In Ramas explanation, he refers to “build.cs”, but where is this file?

You know, I don’t want to become a rocket scientist here, just a few more words to explain what a non-programmer has to do to get this to work.
I thought that was the background logic behind this whole Steam setup program.

Thank you very much!
Somehow I didn’t have C++ files, maybe that’s because I’ve created the project with one of the very early UE4 versions that came out. However, after doing what you said, it created C++ source code for the project and now I can find the requested files.
I’ve followed the video as best as possible and did all the cleaning and rebuilding.

When I run the game from within the editor as stand-alone, I can see the Steam overlay. Does that mean it worked?

The editor still shows me this at startup:
LogOnline: Display: STEAM: Loading Steam SDK 1.32
LogOnline: Warning: STEAM: Steam API disabled!
LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()
LogOnline: Warning: Unable to create OnlineSubsystem module Steam
LogOnline: Warning: Unable to load default OnlineSubsystem module Steam, using NULL interface

Yes! I can see the achievements and unlock them now!
Thanks a lot!

You made my day, Ill give it a try later, thank you for sharing!

Sounds absolutely brilliant, should be pinned.

Be awesome if someone ported this to OS X :wink:

Hi.
I am trying to introduce a steam Works using the official Demo " ShooterGame " of Epic. The procedure is as follows .

  1. Download the " ShooterGame " Create a Project in UE4.76.
  2. Right-click the " .uproject " to create a sln file performs a generation .
    3 . We set up to adapt the sdkver 1.30 use the Steam Setup Utility.
    4 . Then I do a rebuild clean up in VS2013.
  3. After deleting a binary file , " . Uproject " is set click Start

Can not external users and play even if the Search and then by performing CreateRoom. How do Will may be adapted to in the SteamWorks?

I have filled in the three boxes with the correct locations but it fails to find some of the configuration files…

It cant find the WinPlatform.Automation.cs or the SteamVRPrivatePCH.h

Also what does the tick box “is Binary UE4 version” mean?
I’m guessing it has something to do with using visual studio and github (I am no coder so both those are unfathomable mystery’s to me)

If I have the Binary UE4 version ticked then I get an error saying “Could not find part of the path 'C:\Program Files\Unreal Engine\4.8\Engine\Source\Programs\AutomationTool\Win\WinPlatform.Automation.cs”

Awesome project, Keep up the good work!

Can someone confirm, that this tool works with SDK version 134? I’ve been trying to setup my Top-Down BP project with this, but haven’t been successfull so far…

Like the last two people, this didn’t work for me. It confirmed that it found all the folders but it didn’t modify the defaultengine.ini for me either (so the package/cooked release had no Steam overlay). There was only one DLL under the ThirdParty\Steamworks\Steamv132\Win64 (steam_api64.dll) which I think Unreal copies automatically anyway. Also, I changed v132 to v134 in the program since that’s what the SDK is labeled but that only v132 showed up everywhere. In other words I may have done something wrong or the program no longer works.

I’m also just Blueprint and I’m working from the Third Person template.

I am getting this error too! Where is this file? (I have the normal binary engine)

Also when I open UE4 I get this in the logs:
LogOnline:Display: STEAM: Loading Steam SDK 1.32
LogOnline:Warning: STEAM: Steam SDK 1.32 libraries not present at …/…/…/Engine/Binaries/ThirdParty/Steamworks/Steamv132/Win64/ or failed to load!

I am using the 1.35 SDK so I’m not sure why it’s looking for 1.32 :confused:

EDIT:

I found out that the UE4 NOT from github only supports up to v1.32 so I’ve used that instead (Older SDKs found here: Steamworks)
Also I never used the Utility in the end due to the error above but instead the poorly explained tutorial here: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums
It seems to work fine. I finally get the steam overlay in my game so that’s a milestone.

Thanks for the heads up Lazy Games. It’s good to know that you need to use 1.32. Quick question: does it modify your DefaultEngine.ini lines to show Steam in it? I assume it needs to but it didn’t for me.

This should be at the bottom of your ini file:


[/Script/Engine.GameEngine]
!NetDriverDefinitions=ClearArray
+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam
PollingIntervalInMs=20
bHasVoiceEnabled=false

[OnlineSubsystemSteam]
bEnableSteam=true
bEnabled=true
SteamAppId=480
SteamDevAppId=480
GameServerQueryPort=27015
bRelaunchInSteam=false
P2PConnectionTimeout=90
bAllowP2PPacketRelay=true
bVACEnabled=1
GameVersion=1.0.0.0

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

[Voice]
bEnabled=false

I believe the app ID must be changed later when you upload to steamworks. Playing straight from a packaged game shows up on the steam overlay as ‘spacewar’