Download

Steam Sessions Invalid on 4.24 source BuildUniqueId: 0x00000000

As seen in the log below session gets created but has a invalid BuildUniqueId which makes the session not searchable or joinable, I have tested this on binary 4.24.3 and this isn’t present and session are created with out any issue. any idea why the source build carries this issue?


[2020.05.09-05.34.56:235][565]SteamCoreLog: Warning: Created session! My Session
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS: dumping NamedSession:
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     SessionName: My Session
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     HostingPlayerNum: 0
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     SessionState: Pending
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     RegisteredPlayers:
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:         0 registered players
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS: dumping Session:
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     OwningPlayerName: [IHS] OverRated
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     OwningPlayerId: [IHS] OverRated [0x1D5B2184A60]
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     NumOpenPrivateConnections: 0
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     NumOpenPublicConnections: 4
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     SessionInfo: HostIP: INVALID SteamP2P: 76561198006150630:7777 Type: Lobby session SessionId: Lobby[0x186000003F549B2]
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS: dumping SessionSettings:
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     NumPublicConnections: 5
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     NumPrivateConnections: 0
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bIsLanMatch: false
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bIsDedicated: false
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bUsesStats: false
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bShouldAdvertise: true
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bAllowJoinInProgress: true
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bAllowInvites: true
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bUsesPresence: true
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bAllowJoinViaPresence: true
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     bAllowJoinViaPresenceFriendsOnly: false
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     BuildUniqueId: 0x00000000
[2020.05.09-05.34.56:649][868]LogOnlineSession: Verbose: OSS:     Settings:
[2020.05.09-05.34.56:649][868]SteamCoreLog: Warning: Create Session My Session Complete! 1

I am,experiencing this. Have you resolved it?

No but it doesn’t affect anything my issue was related to something else.

I have the same issue, Build ID 0x00000000. What was your problem? I checked Default Engine ini often, but I do not see any error. And it was working weeks before.

The build ID doesn’t seem to mater it always invalid on source builds.