Download

Steam Online Subsystem Error

When I try to package my Game which is using the Steam Online Subsystem, it just says WARNING: Steam Online Subsystem disabled :confused: Can somebody help me with this Error?

Log:
UATHelper: Packaging (Windows (64-bit)): ********** COOK COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): Running UE4Editor Cook for project (uproject)
UATHelper: Packaging (Windows (64-bit)): Commandlet log file is (“location”)
UATHelper: Packaging (Windows (64-bit)): Running: (“Location”) Projects"uproject"" -run=Cook -TargetPlatform=WindowsNoEditor -fileopenlog -unversioned -abslog=E:\Programme\EpicGames\UE_4.21\Engine\Programs\AutomationTool\Saved\Cook-2019.03.04-21.29.51.txt -stdout -CrashForUAT -unattended -NoLogTimes -UTF8Output
UATHelper: Packaging (Windows (64-bit)): LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
UATHelper: Packaging (Windows (64-bit)): LogInit: Display: Running engine for game: Game
UATHelper: Packaging (Windows (64-bit)): LogStreaming: Display: Took 0.052s to configure plugins.
UATHelper: Packaging (Windows (64-bit)): LogOnline: Display: STEAM: Loading Steam SDK 1.39
UATHelper: Packaging (Windows (64-bit)): LogOnline: Warning: STEAM: Steam API disabled!
UATHelper: Packaging (Windows (64-bit)): LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()
PackagingResults: Warning: STEAM: Steam API disabled!

​​​​​​Haha ! :smiley: I got the same error and searched and searched without testing my game because I want to fix this error first … :slight_smile:
​​​​​​
BUT the Steam System is working fine in ur packaged game ! just start it and test it. I had the same error and I dont know why the engine is thinking that’s disabled but in your packaged game it will work :)!
So the solution is: do nothing and start your packaged EXE

have fun