Download

Steam Multiplayer Tutorial Series?

Well it works fine in the downloaded project I’m just trying to track down the differences. There is something different.

UPDATE: Actualy I notice in the downloaded project the lobby is not spawning the player on either client

This is impossible to debug as the client doesn seem to post anything to the log

Ok Found it! In the ServerMenu widget Blueprint. In the graph. open the RefreshServers Function.

Comming out of the ForEachLoopWithBreak the Array Element was no connected to the SET AvailibleSession node at the end of the chain.

See here:

MPB_MissingString.png

After that worked like a champ! hope this helps.

Got this working pretty well. Hosted from TX and had my second “client” connect from Ohio - worked out perfectly.
Still trying to figure out that “Available Server List” function lol.

There is a tutorial here that has a server list.

https://www.youtube.com/watch?v=6RlYegIkN0Y

[QUOTE=James Barnette;576628]
There is a tutorial here that has a server list.
https://youtube.com/watch?v=6RlYegIkN0Y[/QUOTE]

awesome, thanks man. this should work out … i may endup breaking the entire thing a few times, but, eventually … i will get it lol …

When launching from the MainMenu map, going through the lobby menu then entering a Map either on LAN or Steam, when I run around and press Left Mouse Button the cursor goes away until I let go.
When I just open Map1 directly to play this doesn’t happen.
Has anyone come across this before?
I’m using 4.13 preview.
I converted the project to be top down; not sure that matters though.

Here is a video showing the issue : https://youtu.be/YBnOmecf7ys

[Update: solved by Rudy Triplett - https://answers.unrealengine.com/questions/466848/cursor-disappears-while-lmb-held.html]
2016-08-11 20_54_13-Calculator.png

[QUOTE=James Barnette;576628]
There is a tutorial here that has a server list.
https://youtube.com/watch?v=6RlYegIkN0Y[/QUOTE]

This is the tutorial that gave me black screen.

The tutorial was so cool!, but i have a problem with Steam conection.

When i host/Join a session in LAN works fine… but when i try to host in Steam i have this log error:

LogOnline:Warning: STEAM: Can’t start an online session (Game) in state InProgress

And when i want to search i have this:
LogOnline:Warning: Unknown or unsupported data type from Steam key data Attribute 0 2237
LogOnline:Warning: STEAM: Failed to parse setting from key Attribute 0 value 2237
LogOnline:Warning: Unknown or unsupported data type from Steam key data Attribute 1 5
etc
etc
etc

i cant find any sessions :confused:

any idea?

4d6cb28ced5faafdd61742ffba3e8de5dae6188b.png

Nevermind, my friend didnt allow the firewall on windows :frowning:

I have the black screen problem at the end of lesson 16 here https://www.youtube.com/watch?v=_-ya...ndZqZ&index=16

Cant join a lan session even though it finds the session. This is what it logs when the server host the game and moves to the lobby

I solved this issue by renaming my computer system, get rid of any accent marks, for example mine was name Vorágine, I renamed it by Voragine. Hope this be useful.

I followed all the tuts and it works in 4.13 in standalone. It doesn’t work from the copy /paste project on one pc. It won’t connect even though it finds the session.
Does this copy/paste project on one pc not work now?, or is there something I missed. Tried with and without steam.
I’m trying to test the save file, but it seems a long winded test to put on 2 comps at this early stage if the copy/paste would work.

I downloaded the Steamproject and opened it in 4.13.
I then copy/pasted it to test the save file and it worked perfectly in LAN but my project didn’t work in LAN. grr

So , I went through all the Blueprint and found no difference.
Both engine .ini files are the same for the Steam setup in both projects
Tried the DefaultPlatformService=Null . didn’t work.

Then I found the problem !!!
The tutorial project has the Steam plugin turned off in the editor

Opened my project , turned off the steam plugin, and tried the copy/paste with 2 LAN connections and it worked.

so to get it working with steam enabled in the editor I changed the engine.ini to
[OnlineSubsystem]
DefaultPlatformService=NULL

[OnlineSubsystemSteam]
bEnabled=false
SteamDevAppId=480

The tutorial did this in the editor instead

Hi,
I downloaded original project and run it on two different computers on LAN, with two different steam account, with enabled all plugins. it host session and find it, join it (fire successful pin), but not load… stays on loading screen and run out of time. i tried on 4.13 and 4.14 version and don’t work on both. why?

Thanks!

Now works but its not connected to steam anymore…

Man this is driving me crazy, I went through the videos to tweak the project again, I fixed what was broken but now I can’t package it! Still Wes’ build works with no problem.

It appears the steam integration (and all subsystem integrations) have been moved to plugins. Also note that it currently is only functional with C++ and not blueprints unless you write your own code to interface C++ in your blueprint nodes.

This is disappointing as I had an entire project reliant on the steam integration and now it will have to wait until hopefully someone writes a blueprint interface. I don’t know C++ or I would do it myself.

Just my luck.

I can never find any match in the INTERNET mode. Is there Steam’s problem?

Hi Wes Bunn!](https://forums.unrealengine.com/member/48-wes-bunn)
I’m new with unreal engine. Thank you for this tutorial I learned a lot in a short period of time. I tried to test the game with a friend and the steam subsystem is not working correctly… I have done the tutorial with the 4.18.3 and everything seems to work fine in stand alone mode or in the editor, I could not test locally the steam integration because I have only one computer so I tested it with a packaged build shipping to test with my friend’s computer and I noticed that there is no steam popup at bottom right when I start the game and steam is open … I also noticed that during the build there is a warning saying ;
LogOnline: Display: STEAM: Loading Steam SDK 1.39
UATHelper: Packaging (Windows (64-bit)): LogOnline: Warning: STEAM: Steam API disabled!
LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()
I have enabled the Steam Subsystem in plugins setup and added these line into DefaultEngine.ini;

[/Script/Engine.GameEngine]
!NetDriverDefinitions=ClearArray
+NetDriverDefinitions=(DefName=“GameNetDriver”,DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam
PollingIntervalInMs=20

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480
SteamAppId=480
GameServerQueryPort=27015
bRelaunchInSteam=false
GameVersion=1.0.0.0
bVACEnabled=1
bAllowP2PPacketRelay=true
P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

When I try to run the game in standalone mode or development win64 I can see the steam window showing up at bottom right but I don’t know if its working…
I spend a lot of time following this tutorial so it will be nice to get it working…
I did everything like in the tutorial even some step that you don’t show in the tutorial like the world settings to set the gamemode and the player controller and more…
Please help!

I fixed it by adding in WindowsNoEditor\MapName\Binaries\Win64\steam_appid.txt to my project. inside of steam_appid.txt I added 480 and Voila! Steam is showing up in my game!