Steam Multiplayer Stops Working After Package

I am sorry if this has been asked before but I am bad a searching for solutions. I am trying to make my first multiplayer game and I am having problems. I used this tutorial: Unreal Engine 4 - Steam Multiplayer - YouTube to make a multiplayer game and it worked fine when I tested it in the editor with two players. However, when I packaged it and launched two instances, I could not find any sessions when searching for them. Why could this be? Thanks.

Hey Rymazon!
The tutorial you watched is very brief and kind of vague. I recommend watching the Official tutorial series that Unreal Engine made. Blueprint Multiplayer: Project Overview | 01 | v4.11 Tutorial Series | Unreal Engine - YouTube

This series is made in 4.11 but I have 4.20 and can verify that everything works perfectly, including Searching for and Joining games AFTER packaging.

The only thing I can tell you is that if you are packaging your game and trying to search for game sessions. You cannot do this on the same PC and cannot do this on the same Network. I’m not 100% certain on the reasoning as to why, I vaguely remember hearing about it when I did followed these tutorials. However, I recommend using 2 different networks on two different PC’s and searching for your sessions then. (I used my phone as a mobile hotspot on my laptop and it worked flawlessly)

Thanks for the suggestion, but i figured it out.

I figured out my problem. When I tested it on 2 PC’s one dint have steam open so it couldn’t connect to the servers. When I did it both on the same PC it dint work because they were both on the same steam account.