Steam Multiplayer not working

First off, I’m using Unreal 4.18, and following the tutorial UnrealTek has set up. I’ve copied the lines into the DefaultEngine.ini





I’ve enabled the Steam Online Sub system in the plugins and ran a standalone game. After following all of these steps, the game is still not calling Steam. Does anyone know why this could be happening?

My guess is either your steam is not opened or the in game overlay is not enabled.

That’s weird have you tried restarting the editor maybe steam too ? if that doesn’t solve it I’d test it in a new project.

Is it a BP or C++ ? also if you can upload a copy of a new project or something with the same problem I can see if does work on my computer.

Both Steam is opened and the in game overlay is enabled.

Lol, I’ve actually done that already. I’ve closed steam and unreal multiple times. Created a new FPS game and ran the script in that… I’m getting the same results. This is why I’m completely stuck… Not sure what could be causing this…

I haven’t gotten to the BP or C++ part yet. I’m strictly trying to get Steam to register in StandAlone. I’m Launching a Standalone game in the editor so the overlay shows up… I’m create a zip and send it over.

Okay, sounds good.

Not sure why you deleted your comment but Steam worked perfectly fine with the project you sent.
Changed nothing.

Huh… that’s so strange… I deleted the first comment because It was linked to a different google drive that i didn’t want accessing to… the second comment, not sure why or how that got deleted… lol in any case, i’m glad that its working over on your end… it might just be my computer then! I’ll check it out on my laptop double check. Thanks for taking the time to debug

No problem I’m glad I could help, Good luck with your project.

YES! It’s working on my other machine! Thanks! :slight_smile:

Awesome :smiley: