Steam find session not find anything in packaged game

Hello everyone.

I have multiplayer UI setup done. Steam overlay working fine too (when i launch the game i can launch steam UI and its showing me as playing “spacewar”) HOWEVER i cannot connect my 2 separacted PCs.
Findind sessions on 1 PC take about 5s time in editor (and it works, client1 can see client2 and they can connect each other) but in packaged game searching take only 1s (i suspect this) and PC1 cant find created session in PC2…

What i have done:
-Enabled module steam in editor
-changed defaultengine.ini text
-created steam_appid.txt (480) file in packaged game folder

So after all, finding sessions not working.

I also tried to modify build.cs file:
but i dont know how to compile that so if i modified and saved that file, i got error in packaging build so i didnt changed anything in build.cs file… I dont using C++ but i have that build file because some months ago i tried to install one plugin which required c++ setup.

Could someone recommend me tutorial or give tips how you guys did steam finding sessions working?

How many Results do you Set as Maximum?
Cause since ID 480 is allover the World used for Development, Spacewar can result a few thousand result sessions.

A good solution:
Use AdvancedSession and Filter your Results for the servername/gamename or any other YOURGAME Related Property.

Thanks a lot. That was it :slight_smile: before i had “find results” like 10, now i set it to 20 000 and my notebook found PC.
However, another error appeared: ping is 9999 and if i connect PC->NTB or NTB->PC, both crash… Server game crash and client game is returned back to main menu… do you have also experience with this?

Interesting… Very interesting…
I packaged game through “project launcher” and its running PERFECTLY on both PCs, they can connect each other and without bugs which i had in packaged game…
edit: but im a little confused now… that packaged project contains uassets like in my editor… so now im unsure if someone can modify/steal these uassets from my project…

to stop people from modifying or editing your game files, in settings, project settings build settings, set it to build as .pak :slight_smile: