Steam Cloud not synchronizing between two PCs

Hi there

We are very close to release a game on Steam. Unfortunately, there is an issue. The Steam cloud save game does not synch between multiple PCs with the same Steam account. It works fine as long as I stay on the same PC. I can save, all is uploaded to Steam, then e.g. delete all local save files. When beeing on the PC where the savegame was saved, it downloads fine from Steam. But when installing the game on another PC, the save game is not synched. In the launcher, the cloud does synch and says all is ok. But that’s not true.

The achievements get synched fine. But the actual save game of the game does not. Anybody any idea what I’m missing?

I’m using Steam Core. SDK is set up, App ID, Steamworks, all is fine and configured. And as I wrote, all works fine, just not between two different PCs.

Thanks to all!

Hey @nobodysproduction
Could you provide a screenshot on what you’re doing exactly utilize the Steam Core? It sounds like its not communicating with the server properly.

@ ZenLeviathan

Many thanks for your reply!

This is the config on Steamworks

This is the config in the project settings:

The Web part is not configured (and not needed, right?)

Here I upload it (Of course there are all the save functions before this. After saving everything, I do a upload like shown below):

This is how I download it from Steam and then load it (According to the build feedback from Steam, no files get downloaded):

This happens on Main Menu construct, which is the very first thing loaded, before everything else.

Additionally there is of course all the stuff with the SDK that has to be at the right place and so on. But I’m regularerly uploading builds, achievments are working. This should all be fine. Without having added the App-ID within the correct files and stuff, nothing would work.

Has anybody any idea how to fix this?

Hi everyone

Unfortunately, this is still not fixed. Any help would be very much appreciated. Maybe @ZenLeviathan?

Thanks a lot!

Hey @nobodysproduction
Sorry for the delayed response! My best guess for help at the moment would be to try and implement some Blueprint debugging, these breakpoints might help you determine where the code stops working - Blueprint Debugging | Unreal Engine 4.27 Documentation

I’m about to try and recreate your issue, but the only thing I could truly see from sight could be some kind of discrepancy between the saved and loaded files. I’m not entirely sure why, but that is my guess.
I hope this can help a bit, and I’ll get back to you!

Thanks a lot! Let me know if you find the issue! I was still not able to fix this.

Thank you very much for your help!

Hi there!

Where you able to figure this out?

I checked again everything. Repeated several tutorials step by step. It should be all correct…

Thanks a lot!

Did you figure this out? I thought you didn’t have to have code in-game to load the Steam Cloud files? I thought Steam handles that before the game loads? I’m sure that’s what it says on their doc page :thinking:

In this case, how does steam know which files to load or save? There is no way to define the folder or specific save game file outside of the game. Where can I define this then?