Download

Steam App ID Not Working...

I have successfully gone through the Steam Greenlight process and I have received my Steam App ID for Riders of Asgard. I have also successfully integrated the Steam Online Subsystem as well as the Advanced Sessions plugin and everything works fine when I am using the default App ID of 480.

As soon as add my Steam App ID nothing seems to work.

Is there some trick to using your own Steam App ID?

I’m also stuck on this Issue. Did you ever figure it out?

No I did not come right … I am still not able to test my game using my provided Steam APP ID.

Sorry to hear that. Its disheartening for anyone looking ahead to launch.
Had hoped by now there would be a simple reliable roadmap for Steam…
Yet here we are in 2017 & the usual Steam probs continue to trip devs up.

same problem on my steam

unreal engine the best game engine mmocake the best maplestory mesos platform 100% safe

I have run into this problem too.

@Tesla and @xiaoshumiao and @bigpapaleo … do you think this is a Steam problem or an Unreal Engine problem. I have tried a few other things and yet I am still not able to test it. My next step is to try the Steam Setup Utility, but at the moment I am not too optimistic.

I would like to hear from other developers who have released a Steam game using Unreal Engine.

EDIT: I posted a question on the Steamworks Development group … will see what responses I get there.

Okay … it is as I suspected … you need to have your base packages up on Steam first as Steam doesn’t know you have the game in your library.

So, I will spend some time getting this all working and I will even get a demo of Riders of Asgard up on Steam. Hopefully then I can move forward, so many hoops. 8-}

Okay … so to everyone who is having this problem, it turns out that sometimes the default packages don’t get created and you need to get Steam to add them. There is a quick way to check and I have added some screenshots to show you what you should be looking for.

Log on to your Steam Partner page and go to the main page of your game.

Check if you have something similar to the below image listed at the top of the page:
Capture.PNG

If you don’t then you need to contact Steam Partner Support to get it added. You can confirm it is added by clicking on the link below, on the same page:

7e579e4fa5d2535730817849d54fd0338008040a.png

And then looking for these entries near the bottom of the resulting page:

3a7f6ca50b92f4a1d40419003c1b2f536ec36cdc.png

If all that is there then your default packages are correct and it should all work. If none of those entries are there, contact Steam Partner Support and they will quickly add it for you. I got mine added by joining the Steamworks Development Group (http://steamcommunity.com/groups/steamworks) and asking for help there: http://steamcommunity.com/groups/steamworks/discussions/0/144513248270856551/

Steamworks Partner Support saw my post, checked my app and added the packages for me … and so now when I am testing my game with Steam logged in and the Steam subsystem configured, I finally have this:

c5a9a8a93098351228d93c2c79856898bc66776a.jpeg

@bigpapaleo @franktech @xiaoshumiao @Tesla So for those of you struggling with this, it was a Steam problem and not an Unreal Engine problem and the only way to get it resolved is to get in touch with Steam Partner Support. I must also reiterate that this doesn’t always happen.

Kudos! Cheers and good luck with Riders of Asgard…

NICE!! I’m out of town right now. I’ll try it out soon. Thanks for sharing!!

It worked! Thank you for your help @qdelpeche!!!

@bigpapaleo: Glad you came right and I am glad I could help. 8-}

Hi @qdelpeche I actually haven’t had this problem but I’m facing some different issues with steam, maybe you could help me out, I’ll link you to my thread so I don’t high jack yours https://forums.unrealengine.com/showthread.php?138095-Questions-on-setting-up-amp-building-a-steam-game-for-non-c-users

thanks in advance

Thanks for the solution. I will try doing this as soon as I can.