Steam API Disabled on Desktop but not Laptop

Same project, copied over to my laptop, works fine out of the box.
Same project, originally from desktop, played on desktop, disables Steam API.

Not sure what’s going on. I am attaching logs, dxdiag, project. I am following the BP Multiplayer tutorial series. It’s bugging me that I can not get the Steam Overlay on desktop.

Project link:


Both PCs have steam running, two different Steam Accounts.

The funny thing is, I am not the only one having this issue though: Blueprint Multiplayer: Find a Match Graph | 11 | v4.11 Tutorial Series | Unreal Engine - YouTube Look at the comments

Ah and before I forget. The Multiplayer aspects work. I can host from my laptop and join in from my desktop. The only issue is Steam API being disabled from Desktop (it never shows up). And one more thing. Both are running in Standalone.

Both Windows10

As a sanity check, both computers are running Steam? And, both computers aren’t logged into Steam at the same time?

I know this is a simple question but its sometimes best to eliminate those first.


Are both your desktop and laptop running Windows?

When you say transfer project, is it the whole UE4 project or a packaged build of the project?

the whole project. I didn’t even zip it.

It’s really bugging me. But I am kind of glad I am not the only one…although I am curious what could be causing this on one system but not the other. Maybe I’ll post the logs for laptop here as well. Along with dxdiag.

laptop dxdiag
laptop logs

Both are running in Standalone Game mode. According to others, this should not work in PIE.

I did have issues with Epic Launcher freezing up on my over that last few weeks, I sent that report over to that helpdesk. But, I haven’t heard back from them. I wonder if it has anything to do with that. But over the past few days, I haven’t noticed my Launcher freezing up.

Ohh, good question. They are not the same builds, I am looking at both dxdiags now. I had assumed both were on anniversary. Looks like my laptop is NOT on anniversary… I hate this anniversary update…caused me quite a bit of other problems actually.

The logs you posted have, “Steam API failed to initialize!”.

I am just trying to figure out why.

I think the underlying cause is because it is two different computers with different features and settings.

Moving forward, at what point are you expecting Steam to work? Is this while in PIE? Or, is it after you package the game on each computer? Overall, how are you running the game when you expect it to startup SteamSDK?


Are both your computers updated to the same version of Windows 10?

As an example, maybe one has the anniversary edition and the other doesn’t.

I know the anniversary update has been a bit of a nightmare.

On top of that Steam in general has some rules based on what build type it is and what OS, where sometimes the SDK wont kick off correctly.

Hmmm, so, I guess I’m stuck, I’m not in the mood to try to revert back to pre-anniversary, I could only image that horror.

Assuming that’s the issue. I just want to confirm that’s something that Steam has to work out on their side correct? Nothing you guys can do on your side?

So, after some debugging on Unreal Slackers… someone asked a really simple and good question:

“Did I disable Steam Overlay at any point” and of course, I don’t really play too many games anymore but I did remember doing so at one point… #facepalm

Sure enough, after reenabling the overlay on Steam, SteamAPI does not get disabled.

I have to try and track down a machine that has the Windows 10 Anniversary edition on it in order to test this. Forgive me if it takes a while.

Thanks for the report and I will update you as soon as possible on any resolution.