Steam achievements not working outside of editor

I’ve got this issue, where my game’s steam achievements work only when I launch the game as a standalone game from inside the editor. But I’m not even getting the steam overlay pop up in the packaged game. In the build I uploaded to Steam itself, I get the overlay, but the achievements aren’t triggering at all.

Is there something obvious I’m forgetting about?

I’m using whatever the latest steamworks version is (v146 I think) and engine version 4.19.
Is there a limit to how new of a steamworks version I can use with 4.19?

I think I fixed it by using an older version of steamworks (v139).

What exactly did you do to make packaged version work ?

I honestly can’t remember anymore (It’s been 2 years+), but I assume there was some kind of conflict with a newer version of steamworks than the engine version was compatible with. I would have most likely downloaded an older version of steamworks and copied the dll-s from there into my engine folders according to this: Online Subsystem Steam | Unreal Engine Documentation
The ones from the Steam installation would have still been the newest ones.

Sorry, I can’t be of any more specific help.

I tried to update the engine to support newer version of steamworks sdk, but it didn’t work.
I cant even rebuild (there is no button) the changed All I can do is save the change and that does nothing.

Thanks for the reply.

Turns out , I needed to make steam_appid.txt with my game number on the first line and put that file in some of the shipping build folders (as described in the online subsystem steam documentation).
There are two executables in my case so I put the file in both folders (and the game root just in case). Then upload the build on Steam and now it works.