Download

Staying under the 50 MB limit

I’ve found many topics of people trying to figure out how to reduce the size of their project. Answers though, not so much.
I can’t even get my project under 50 MB, despite having a content folder at a total of 14 MB. Which means that I can’t even submit it. Even with just a single texture format, I’m hovering around 60 MB total. Nothing I do can get it lower. I even managed to shave 10 MB out of my content folder at one point, and that only dropped like 4 MB from the final .APK. That means I could have an empty content folder and still be over 50 MB.
I know there’s a way to do it, because Tappy Chicken is like 23 MB. And also, no one would ever get a game on the App Store without getting around this.
Anyone have tips?

Try disabling plugins. I know I got like 15 megs off but got some paper 2d warnings on startup.

Hi Grimwolf,

As of 4.8, support for downloading .obb (large data) files from the Google Play Store has been added, so you are no longer obliged to stay under the 50mb limit and can utilize the APK expansion files.

Actually, I stumbled across a pretty simple solution.
Inside project settings > packaging, turn on “create compressed cooked packages”.
For some reason this is off by default, and turning it on cut my project size nearly in half.

Also, how do you disable plug-ins?

Hi Grimwolf,

The compressed cooked packages should have defaulted on; I just checked it does in 4.9 at least.

The plugs dialog is accessed from the Edit menu. You will need to have a code project for changes to take effect since this will need to compile a new library without the code; enabled plugins are compiled into the same .so on Android and iOS. If you only have a content-only project (Blueprints and no C++), you can just add an empty class to make it a code project.

I don’t have a list of plugins to suggest disabling, but Leap Motion in Input Devices is worth turning off as it tries to package assets you don’t need. You may also turn off Gear VR, Oculus Rift, and SteamVR.

Hey Grimwolf,

Check out the following document for ways to go about reducing the size of your APK package.

https://docs.unrealengine.com/latest/INT/Platforms/Android/ReducingAPKSize/index.html

Let us know if you have any questions or issues getting this to help you reduce your APK package size.

I was trying what Chris suggest to remove the plugins from my project… simply installed VS 2013 and added a new empty class, tryied to package it and the build fails… :frowning:

Check my answerhub here: APK grows in 4.9 and hwo to get rid of VR plugins? - UE4 AnswerHub