Stationary lights BUG

Hello !

I’m working on a new project and I have some problems with my lights.

I created a blueprint to play and toggle with my main light (it was just a test) but after building the scene, there is a bug with that one :
As you can see in the preview when the light is “on” everything is ok! but when I turn it down, the light seems to be still here (you can see the orange color on the ceiling)



I tried to remove my blueprint, I created a new one, built the all scene with “force no precomputed lights” checked, rebuilt again… but the problem is still there and I don’t know what to do.

I have an other problem regarding the stationary lights on the wall, they simply don’t work except one and I haven’t got any red cross…



Hope I could find a solution :stuck_out_tongue:

AFAIK stationary light can only have it’s intensity changed (cause it’s partially baked)… Try to set it to movable.

Force no precomputed lighting will prevent any baking…but if your lights are static or stationary it will not work, they need to be set to movable (almost sure).

Ok then I’m gonna change the parameter of the main light and rebuild the scene but what about the other ?

It’s not a blueprint, just a simple stationary light so I don’t understand why I got this problem because there is no redcross at all :frowning:

For the first case, make sure you’re changing the intensity, and for the second, make sure the light can actually illuminate that correctly–it looks like the light might actually be blocked by geometry. Also, don’t use stationary lights unless you need to–that’s if they need to affect dynamic objects or they need to have their intensity/color animated. Otherwise use static lights.