Static shadows not baking anymore (not related to lightmap resolution)

Static shadows stopped appearing properly, even if I load a previous autosave of when things were fine and rebake, they disappear, any ideas why? The map file size gets much smaller than when it was working.
Already tried deleting and remaking the outdoor volume, same for the lights, lighting channels are set properly too

Map being smaller as no light/shadow information stored. Check your meshes properties to see if you haven’t turned off shadows

Nope, everything is on, it’s weird because I noticed my tree trunks and some meshes are baking shadows, but others not, even a newly imported tree with the default checkboard material isn’t baking