Download

Static meshes have no materials when I drop them in my map

Hi,

I just recently downloaded UE4 and have migrated my downloaded sample projects to my current project. I’m not an artist/modeler so I’m relying on all of the free assets I can get. The problem is, when I drop a static mesh into my map, there are no materials applied so all of my objects are grey. I’m sure it’s not too difficult to add the corresponding materials to their static mesh, but I’m a little rusty as I’ve been out of the game design loop for a while. I have tried dragging and dropping a material onto it’s according static mesh, but the result is extremely unsatisfiying. For example: I dropped in one of the snow trees from the Elemental demo, then went to materials and added a snow_tree material to the mesh, but it didn’t align properly at all and just looks like a 2d painting of leaves was slapped on to the surface of the mesh. How would I go about applying these materials correctly and am I going to have to do this for EVERY single mesh I want to add to my world? If so this is going to be a very tedious process to get me setup. I’m coming from UDK where I could just drag in a static mesh that I wanted and it would have its materials already applied.

Thanks,

Skisma

To assign a material to a mesh, you just have to do a double click onto it and in the static mesh editor you can assign them to the material slots. When you migrate stuff from a project to another one without the same folder structure, all the linked textures and materials are gone. So you will have to re-link them. You will have to do some improvements in the material to get a good looking result (e.g subsurface scattering, wind effect http://www.youtube.com/watch?v=bAzKVaH0IZg ,…)

Thanks for the reply! Now that I think about it, I didn’t actually migrate them (sorry I’m just getting back in the swing of things). What I did was, I moved the downloaded projects from My Documents>Unreal Projects to Unreal Engine>4.2>Engine>Content. This way I just select “Show Engine Content” in the ‘view options’ of my content browser, so I don’t have to migrate all of the assets each time a start a new project. That being said, I’m pretty sure the folder structure is the same. Any idea why the materials/textures got unlinked?

Ok last night I tried the 3 different methods I’ve been taught on how I can access all of my downloaded sample projects/assets and only one of them resulted in the textures/materials staying with their according meshes.

The first method I tried (the one I stated in the OP) was cutting the projects (Elemental and SciFi Hallway) from My Documents>Unreal Projects and pasting them to Unreal Engine>4.2>Engine>Content. Then I went into my projects content browser and checked the box that says “Show Engine Content” under view options. This resulted in all meshes losing their materials/textures.

The second method I tried was very similar; I cut the projects from My Documents>Unreal Projects, but then pasted them into Unreal Engine>4.2>Samples>Content>Sample Content (this file path may not be exact, I’m basing off of memory). When opening a new project I selected “Show Starter Content” and got the same result.

The third method I tried was migrating the assets from the sample project to my project. This worked! When I drag the meshes in try actually look like how they’re supposed to. My only concern is, I’m not happy with this method. This is going to be way to tedious if I have I do this for every single project I create. I’d like I have all of theses downloaded assets available in my content browser as soon as I open a new project.

Any ideas on a method I can do that while still keeping materials/textures linked to their static meshes?

Thanks!

I don’t have a specific answer, but maybe a good work around. What if you create a dummy project, and load all the stuff you want in that one, and then just always migrate stuff to or from that project into your new one.