Download

Static mesh visibility flicker

Hello,

I’ll try and keep this as short as possible, I’ve attached some images to help explain my problem (sorry for their hugeness, can’t seem to hide them):

Problem:

  • My static meshes flicker, going from invisible to visible (or so it seems) multiple times per second (visible: Columns_fullview.png; invisible: Columns_fullview_flicker.png).
    These are meshes I made in Maya (Polygon Cilinders with 4 sides, 500 units high, radius of 17.5 units), imported into Unreal Editor as FBX files (v. 2014). I made 2 uv’s, 1 for texturing (Column_texture_UV.png) and 1 for lighting (Column_lightmap_UV.png). These are far from perfect, I only made it to demonstrate the problem with the simplest of objects.
  • This is the standard FP view project template (no blueprints) with some columns & BSP’s in front of it. Lightmap coordination index set to 1, lightmap resolution settings changed between 64,128 & 512.

When I view them from the back (Columns_fullview.png) everythings fine. When I view them from the front, partially covered by the BSP’s, they start flickering like mad.
I’ve tried stretching my UV’s & rearranging them, but to no avail. When I make shorter columns (100 units high) & stack them (do not want this, just did it to try & isolate the problem) they seem to stay visible all the time.
Seems like a real beginners (which I am) error but I cannot seem to find the cause.

TL;DR: static meshes flicker like this guys skeletal meshes: Skeletal Mesh Flickering - Content Creation - Unreal Engine Forums (he included a video)

As this person points out, one of the tutorials shows it too:
https://answers.unrealengine.com/questions/121635/pillars-flickering-after-level-creation-tutorial.html
Video at the time of the flickering http://youtu.be/xxrydy8ZlV8?t=7m45s
I tried changing the bounds scale to 1.5 before but that didn’t help, I just set it to 2 in and that seems to remove some of the flickering.
The tooltip says it reduces performance & shadow quality tho. I’d like to know what’s causing it exactly and if I can prevent it through better design of my columns somehow.