Static Mesh UV Issue

I’m having an issue with imported meshes having UV issues. I’m not really quite sure how to fix it and have tried several things from lightmass settings to mesh editing to texture editing.

Error X Object has overlapping UVs.
Info X Lightmap UV are overlapping by 52.4%. Please adjust content - Enable Error Coloring to visualize.

*all of the meshes in here except the player sized brush, for reference, had these errors.

Visual effect of the error:

Error Coloring seems to show nothing? Have tried differing light properties, preview to production.

If anyone has any idea what’s causing this or how to fix this, I’d appreciate any insight since I’m super new to this.

when you import, are you selecting “Calculate Normals” ?

Please try that if you have not already.

I have tried selecting “Calculate Normals” but the error hadn’t disappeared. The funky/cool lightcamo still appears. Would it happen to to be something to do with the light map coordinate index or resolution of the mesh?

Edit: Messing around I noticed that by making the meshes movable the error no longer persists and the visual error disappears and everything looks fine, however isn’t that a performance drop and not a good thing overall?

The error is because your lightmap UV’s are wrong, your second UV channel is supposed to be your lightmap UV’s, they can’t overlap because you will get errors like you have there. You can try generating lightmap UV’s in UE4, or for better results you can do it by hand in your 3D program and export it back to UE4.
When you make your object movable it is making it dynamic, which can’t use the static lighting–static lighting gets better results but can only work on things that don’t move.

Here is a tutorial how you can create a 2nd uv channel:
Also make sure that you change the lightmap resolution from 32 to e.g 128 and that you have a lightmass importance volume in your level

ago i had this problem and it very Tease me!

i see this new problem in ue4 and i did not see in UDK!

i solve my problem with create 2nd uv channel and setting resulotion from 32 to 128 or 4!

so today i after importing my model into ue4,i can not solve my this problem!

and i see like this:
Info X Lightmap UV are overlapping by 95.0%. Please adjust content - Enable Error Coloring to visualize.

Info Y Lightmap UV are overlapping by 14.2%. Please adjust content - Enable Error Coloring to visualize.

what are these?

ue4 rendering has very very problem! :(:mad:

So your meshes have a 2nd uv channel with a proper lightmap? Also check if you have set the lightmap coordinate to 1