Download

Static Mesh/Skybox - texture quality not sharp, what am I missing?

So I’ve been trying to import material to make a skybox/skysphere other than the clouds as I want a space/stars setup for what I’m doing.

My current process has been:

  • Create spacescape files
  • Import to CubeMap
  • Export as DDS
  • Import to unreal

I then follow the process of creating a static mesh/actor, then creating a material with it, dragging that in as my skybox and applying the space material. It works great, and it is all lined up. HOWEVER, it looks like a low quality/terrible compression jpg when it comes to quality. I managed to pull some detail out by taking mips and turning them to “none” on the material import. I’m guessing there may be compression settings that might also aid to this?

I figured I would pick some brains on this because I’ve been searching for a while now and haven’t found any definitive solutions or discussions on this particular problem. I can take some screenshots if need be and if it would help. It’s driving me crazy because the textures look amazing in cubemap, and in spacescape, and even when i zoom out to check the quality. Once it goes into UE4, it looks terrible.

-Which texture resolution do you use?
-do you get the same result when you import it as a png?
+here is a good skydom tutorial: https://juarez3d.files.wordpress.com/2011/06/tutorial_animated_skydome_v1-3.pdf :slight_smile:

Hi Fighter5347,

Thanks for taking time out of your day to respond.

I exported my dds file as a 2048, however, upon importing it into unreal, it shows up as a 1024x1024.

Here’s a preview of the photo and what I’m seeing.

Here is a picture of my current settings for this particular import of this texture.

Thank you kindly for the link to the skydome tutorial, I will give it a read and see if it can help me make a better dome. Ultimately I just want a skysphere with a spacescape that is very basic and isn’t pixelated. Again, thank you kindly for your time.

Ok, quick update. I dabbled with compression settings, and then the imported texture settings and had some success. I did not change resolutions, just compression, and texture settings. Current result is this:

Settings changed:

  • Compression set to VectorDisplacementmap (RGBA8)
  • Nomipmaps

Texture changes:

  • On Material Expression Constant, reduced to 7.5 from 10

After compiling with these settings and then running the game, the skydome/skysphere is MUCH more clear. The reduction on the constant reduced the amount of emission which seemed to be brightening it up so much that it was becoming a bit too easy to see variations in pixel colors. Reducing masked it a bit. Figured I’d post an update in case anyone ends up running into the same.

Thanks for these tips, they definitely improved the overall visual quality of the skybox. I’m curious if there’s any other ways to increase the quality/resolution because my skybox looks ok, but is still a bit pixelated. For reference, I’m using 4096x4096 DDS with the setting changes listed above. I also kept the scale of the skydome static mesh at 1 instead of increasing it to 500 (17:22 in this video tutorial). I don’t know if that affects the quality/resolution at all though.

Thats the auto exposure filter. Deactivate it in your Post Processing Volume: