Static mesh quality looks bad from far


I don’t know what is happening, but from far my scene looks like this.

In a few walls, things start to merge as stripes.

(at the center, there’s no skybox, so outside is completely black, at the right, there’s a door merging at the wall).

Have you got anti aliasing turned on in post processing? If not turn it on. Also set your engine to epic mode and see if it makes a difference. Also add in a skylight to see if that sorts the black shadows. Let me know how you get on.

On post process, I couldn’t find the anti-aliasing, but on rendering is set on temporal AA. The engine is already on epic mode, added the skylight (what made a nice improve on the light), but the problem still there…

What is funny is that is something on the wall, but: lightUV is out, the mesh is a cube, so the light UV is completely fine
The only UV mapping wrong is at the door. Pipes and the inner side of columns (the part that is not overlapping the walls/ground/roof) are fine.

For curiosity, this is how it was on the old project:

I’ve just migrate the scene, project settings on both are the same.