Download

Static mesh issue

Hi, I’m a beginner and I have few issues with imported static meshes. 1) After importing most of static meshes, it’s not colored but grey or white. 2)Some imported meshes have square parts (picture). 3) and how should I avoid a Warning report: Static mesh is very small. Thanks for your help.

Square parts

  1. this mostly happens when you havent applied a uv map to your mesh
  2. you need to connect the alpha channel with the opacity link in your material + set the blend mode to “masked”
  3. 1uu=1cm -> so you have to scale it like that in your 3d program

As far as I can see on your picture, you use a speedtree (as a mesh) -> just open the material and add the things from point 2 -> alpha channel
After that you would also need to create a foliage shader setup, but first of all lets make sure that you get rid of your problems :slight_smile:

  1. I don’t know where a UV Map options are located, there are just few options right after importing and there is Generate Lightmap UVs option, but it’s enabled and meshes are still white.
  2. My first issue is gone, but there is another. Tree looks alright only from one side, but when I go on the opposite side, leaves are suddenly invisible.
  3. Solved :slight_smile:

**UV Lightmap enabled: **

429e652a73c0694afe5df85ec3fe0ede0ddaf2e0.png

**Invisible leaves: **

  1. ok, now as I know that you use a right material -> it’s not a uv issue. Just connect a constant vector with a value of 1 to the roughness link in your material
  2. enable “two sided” in your material :slight_smile:

And just for clarification:
In the UE4 you dont find any options for a UV map, you have to do such stuff in a 3d program like blender/3ds max/…

  1. Look at the picture below and please tell me if it’s alright. I guess it isn’t, because after I save it, colors appear just for a second and then disappear and everything is the same as before.
  2. Solved, yeah it wasn’t so difficult :smiley:

503a8a91908e7d587a79dbc2973ca8039e65f7c7.png

-you have to add a texture into your material (connect it with base colour and the alpha channel with opacity mask)
-connect a constant 1 vector to your roughness slot (press 1 + left click into the material window) with a value of 1 -> after that the white “shiny” parts should disappear :slight_smile:

OK, thanks a lot! I’m quite busy now, so I’ll try it later, but it should be ok.