Static Mesh Groups bad pivot point

ok i use static mesh Groups a lot when building maps, the main problem being that the pivot point of the group doesn’t snap to the grid, this means that when moving the groups around the map they will not line up, yes i’ve tried to un-group and then Ctrl-End but that doesn’t set all the meshes to grid, to be honest i don’t want to have to reset every mesh in the group every time i use it.
i realise that my work flow may not be what your guys use but surely the pivot point of the group should be a grid point when you create the group and not the exact center of the group

Hello George,

Thank you for your report. The way that snap works is that it does not snap to the grid but instead to distance intervals. This is a known misnomer and is being looked into by our developers. Until the issue has been resolved, please consider using Shashank’s workaround for now.


thanks Wes for the update, it’s good to know that the little issue is being looked at, most likely my workflow because most of my groups are actually builds made from multiple static meshes (20+), with odd outlines which nearly always puts the center off grid

I just tried grouping 2 Static Meshes in the world. Their pivot forms between the both of them, and if I enable Snapping option, the pivot even snaps. The only issue that comes is, that its not necessary and actually very rare that the pivot will form on the Grid lines, because its calculating the average distance between every Mesh in the group while forming the pivot and the average won’t always come on the grid itself. I sorted this problem in a very simple way: switched snapping Off, zoomed in to the lowest possible unit, aligned the pivot to the Grid line, and then simply switched the Snap back on. And it works. A group snapping to the grid.

If your particular meshes are not snapping on the other hand, make sure you always keep the size in Units of power or 2 or something like that while making the meshes. For example, 64, 128, 256. Even 96 works. I remember the usual height of a player in UDK being 96 units.

Hope this info helps. :slight_smile:

Any update on this? The issue is still unsolved.

Hi Starseeker,

This is an archived post that is no longer tracked from our UE4 Beta. Can you post this as a new questions with a link to this post?

Thank you!